summaryrefslogtreecommitdiffstats
path: root/veslibrary/ves_cpplibrary/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'veslibrary/ves_cpplibrary/src/lib/CMakeLists.txt')
-rwxr-xr-xveslibrary/ves_cpplibrary/src/lib/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/veslibrary/ves_cpplibrary/src/lib/CMakeLists.txt b/veslibrary/ves_cpplibrary/src/lib/CMakeLists.txt
new file mode 100755
index 0000000..51f59d1
--- /dev/null
+++ b/veslibrary/ves_cpplibrary/src/lib/CMakeLists.txt
@@ -0,0 +1,12 @@
+add_subdirectory(encode)
+add_subdirectory(transport)
+
+file(GLOB COM_HDRS "common/*.h")
+
+install(FILES ${COM_HDRS}
+ DESTINATION "include/xvesagent"
+)
+
+install(FILES ../cmake/xlogConfig.cmake
+ DESTINATION "lib/cmake/xlog"
+)