summaryrefslogtreecommitdiffstats
path: root/veslibrary/ves_cpplibrary/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorYatian XU <yatian.xu@nokia-sbell.com>2019-09-10 13:47:16 +0800
committerYatian XU <yatian.xu@nokia-sbell.com>2019-09-10 13:47:16 +0800
commit6c27d22ac7af3d1379a5448eef5894083bcae9ec (patch)
treed5b10cb237d3bb0b1dc172beb42c8ef6f31fc67f /veslibrary/ves_cpplibrary/src/lib/CMakeLists.txt
parent9454af15a87774a642b20f34ecc21a1bd84779c4 (diff)
Contribute C++ implement of VES spec 7.0.1 to ONAP/vnfsdk:
Part2: Makefile, Logging Issue-ID: VNFSDK-466 Signed-off-by: Yatian XU <yatian.xu@nokia-sbell.com> Change-Id: I7215dd01a7189fe4d7a57b05bed2ebc05889ce61
Diffstat (limited to 'veslibrary/ves_cpplibrary/src/lib/CMakeLists.txt')
-rwxr-xr-xveslibrary/ves_cpplibrary/src/lib/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/veslibrary/ves_cpplibrary/src/lib/CMakeLists.txt b/veslibrary/ves_cpplibrary/src/lib/CMakeLists.txt
new file mode 100755
index 0000000..51f59d1
--- /dev/null
+++ b/veslibrary/ves_cpplibrary/src/lib/CMakeLists.txt
@@ -0,0 +1,12 @@
+add_subdirectory(encode)
+add_subdirectory(transport)
+
+file(GLOB COM_HDRS "common/*.h")
+
+install(FILES ${COM_HDRS}
+ DESTINATION "include/xvesagent"
+)
+
+install(FILES ../cmake/xlogConfig.cmake
+ DESTINATION "lib/cmake/xlog"
+)