summaryrefslogtreecommitdiffstats
path: root/ice-server/pom.xml
diff options
context:
space:
mode:
authorMickael JEZEQUEL <mickael.jezequel@orange.com>2018-03-08 16:18:04 +0100
committerMickael JEZEQUEL <mickael.jezequel@orange.com>2018-03-08 16:59:06 +0100
commitdd79a38607c40db86de950b4c1ecdff443fe68f4 (patch)
tree8c21a18c1aa365b1ea8fbe779e7be331ab56550d /ice-server/pom.xml
parentb2727af1d234bae3e64cf31a0af3dfee2d1c91f8 (diff)
fix sonar job configuration
Change-Id: I437da70e82fe970f8455bb45e9454959ec6cfc3c Issue-ID: VNFSDK-39 Signed-off-by: Mickael JEZEQUEL <mickael.jezequel@orange.com>
Diffstat (limited to 'ice-server/pom.xml')
-rw-r--r--ice-server/pom.xml11
1 files changed, 7 insertions, 4 deletions
diff --git a/ice-server/pom.xml b/ice-server/pom.xml
index 3e6d2a5..26f8495 100644
--- a/ice-server/pom.xml
+++ b/ice-server/pom.xml
@@ -30,9 +30,12 @@ under the License.
<name>ice rest API</name>
<description>rest API for HEAT template validation</description>
<properties>
- <sonar.language>py</sonar.language>
- <sonar.pluginName>Python</sonar.pluginName>
- <sonar.inclusions>**/*.py</sonar.inclusions>
- <sonar.skip>false</sonar.skip>
+ <sonar.sources>.</sonar.sources>
+ <sonar.python.coverage.reportPath>coverage.xml</sonar.python.coverage.reportPath>
+ <sonar.language>py</sonar.language>
+ <sonar.pluginName>Python</sonar.pluginName>
+ <sonar.inclusions>**/*.py</sonar.inclusions>
+ <sonar.exclusions>version.py,setup.py</sonar.exclusions>
</properties>
+
</project>