summaryrefslogtreecommitdiffstats
path: root/ocata/pom.xml
diff options
context:
space:
mode:
authorYun Huang <yun.huang@windriver.com>2018-03-14 15:59:42 +0800
committerYun Huang <yun.huang@windriver.com>2018-03-14 15:59:42 +0800
commit3d8a68fb65f118a3d12f8fdf8fd1e39158cfdb1b (patch)
treef4465cc1b305f8523e874b2c6e43d13614a2e050 /ocata/pom.xml
parent428c35e6c074be56bd22dc42ba9c4e828564f674 (diff)
Fix sonar coverage issue for ocata
Change-Id: I716fb55a0da6bced6053084a18c2e2297e6708ec Issue-ID: MULTICLOUD-171 Signed-off-by: Yun Huang <yun.huang@windriver.com>
Diffstat (limited to 'ocata/pom.xml')
-rw-r--r--ocata/pom.xml55
1 files changed, 53 insertions, 2 deletions
diff --git a/ocata/pom.xml b/ocata/pom.xml
index 79e241e2..aae5c5b7 100644
--- a/ocata/pom.xml
+++ b/ocata/pom.xml
@@ -47,10 +47,61 @@
<sonar.language>py</sonar.language>
<sonar.pluginName>Python</sonar.pluginName>
<sonar.inclusions>**/*.py</sonar.inclusions>
- <sonar.exclusions>tests/*,setup.py</sonar.exclusions>
+ <sonar.exclusions>**/venv-tox/**,**/.tox/**, **/tests/**,setup.py</sonar.exclusions>
</properties>
<build>
- <plugins>
+ <pluginManagement>
+ <plugins>
+ <plugin>
+ <groupId>org.codehaus.mojo</groupId>
+ <artifactId>exec-maven-plugin</artifactId>
+ <version>1.2.1</version>
+ <configuration>
+ <executable>${session.executionRootDirectory}/mvn-phase-script.sh</executable>
+ <environmentVariables>
+ <!-- make mvn properties as env for our script -->
+ <MVN_PROJECT_GROUPID>${project.groupId}</MVN_PROJECT_GROUPID>
+ <MVN_PROJECT_ARTIFACTID>${project.artifactId}</MVN_PROJECT_ARTIFACTID>
+ <MVN_PROJECT_VERSION>${project.version}</MVN_PROJECT_VERSION>
+ </environmentVariables>
+ </configuration>
+ </plugin>
+ </plugins>
+ </pluginManagement>
+ <plugins>
+ <plugin>
+ <groupId>org.codehaus.mojo</groupId>
+ <artifactId>exec-maven-plugin</artifactId>
+ <version>1.2.1</version>
+ <executions>
+ <execution>
+ <id>clean phase script</id>
+ <phase>clean</phase>
+ <goals>
+ <goal>exec</goal>
+ </goals>
+ <configuration>
+ <arguments>
+ <argument>__</argument>
+ <argument>clean</argument>
+ </arguments>
+ </configuration>
+ </execution>
+ <execution>
+ <id>test script</id>
+ <phase>test</phase>
+ <goals>
+ <goal>exec</goal>
+ </goals>
+ <configuration>
+ <arguments>
+ <argument>__</argument>
+ <argument>test</argument>
+ </arguments>
+ </configuration>
+ </execution>
+ </executions>
+ </plugin>
<plugin>
<artifactId>maven-assembly-plugin</artifactId>
<configuration>