aboutsummaryrefslogtreecommitdiffstats
path: root/infra-healthcheck/setup.py
diff options
context:
space:
mode:
authorLukasz Rajewski <lukasz.rajewski@t-mobile.pl>2023-05-22 10:42:36 +0000
committerLukasz Rajewski <lukasz.rajewski@t-mobile.pl>2023-05-22 10:42:36 +0000
commit78bbd81a9b1ffc170242e446aa1ae26f4dd1e891 (patch)
tree296740ab94b0ea17609a745efc85305c3ee8bcba /infra-healthcheck/setup.py
parent05a15ef4d6a4e2b2b25f18fb84aa0447019bf228 (diff)
Revert "[INFRA] Use integraion script to run onap-k8s test"
This reverts commit 05a15ef4d6a4e2b2b25f18fb84aa0447019bf228. Reason for revert: <INSERT REASONING HERE> Issue-ID: INT-2226 Change-Id: Ic8ca67b37f5e45eed9a21117abc59422ef117250 Signed-off-by: Lukasz Rajewski <lukasz.rajewski@t-mobile.pl>
Diffstat (limited to 'infra-healthcheck/setup.py')
-rw-r--r--infra-healthcheck/setup.py20
1 files changed, 6 insertions, 14 deletions
diff --git a/infra-healthcheck/setup.py b/infra-healthcheck/setup.py
index ee1ecad..566d844 100644
--- a/infra-healthcheck/setup.py
+++ b/infra-healthcheck/setup.py
@@ -19,19 +19,11 @@ import setuptools
# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
-
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
setuptools.setup(
- name="infra_healthcheck",
- version="1",
- packages=["infra_healthcheck"],
- entry_points={
- "xtesting.testcase": [
- 'onap_helm = helm_onap_status.status:Status',
- 'onap_chart = chart_status.status:Status',
- 'nodeport_ingress = infra_healthcheck.k8stest:OnapSecurityNodePortsIngress',
- 'nodeport_check_certs = infra_healthcheck.k8stest:OnapSecurityNodePortsCerts',
- 'internal_check_certs = infra_healthcheck.k8stest:OnapSecurityInternalPortsCerts'
- ]
- }
-)
+ setup_requires=['pbr>=2.0.0'],
+ pbr=True)