aboutsummaryrefslogtreecommitdiffstats
path: root/infra-healthcheck/setup.py
diff options
context:
space:
mode:
authorMichal Jagiello <michal.jagiello@t-mobile.pl>2023-05-11 14:32:52 +0000
committerLukasz Rajewski <lukasz.rajewski@t-mobile.pl>2023-05-17 07:53:48 +0000
commit05a15ef4d6a4e2b2b25f18fb84aa0447019bf228 (patch)
tree55d0e5eeb2d9f7c6f05f39cc3f395ab718acbfca /infra-healthcheck/setup.py
parent379be6ef16ba5f69b9df76e7ff149ee9efb21a99 (diff)
[INFRA] Use integraion script to run onap-k8s test
Instead of Orange use ONAP script to run that test Refactor docker image build to not clone that repo Issue-ID: INT-2226 Signed-off-by: Michal Jagiello <michal.jagiello@t-mobile.pl> Change-Id: I280b344630860caac96f95b77f76c95db5be32db
Diffstat (limited to 'infra-healthcheck/setup.py')
-rw-r--r--infra-healthcheck/setup.py20
1 files changed, 14 insertions, 6 deletions
diff --git a/infra-healthcheck/setup.py b/infra-healthcheck/setup.py
index 566d844..ee1ecad 100644
--- a/infra-healthcheck/setup.py
+++ b/infra-healthcheck/setup.py
@@ -19,11 +19,19 @@ import setuptools
# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
+
setuptools.setup(
- setup_requires=['pbr>=2.0.0'],
- pbr=True)
+ name="infra_healthcheck",
+ version="1",
+ packages=["infra_healthcheck"],
+ entry_points={
+ "xtesting.testcase": [
+ 'onap_helm = helm_onap_status.status:Status',
+ 'onap_chart = chart_status.status:Status',
+ 'nodeport_ingress = infra_healthcheck.k8stest:OnapSecurityNodePortsIngress',
+ 'nodeport_check_certs = infra_healthcheck.k8stest:OnapSecurityNodePortsCerts',
+ 'internal_check_certs = infra_healthcheck.k8stest:OnapSecurityInternalPortsCerts'
+ ]
+ }
+)