aboutsummaryrefslogtreecommitdiffstats
path: root/test/security/check_versions/pyproject.toml
diff options
context:
space:
mode:
authorMichal Jagiello <michal.jagiello@t-mobile.pl>2023-04-19 09:53:38 +0000
committerMichal Jagiello <michal.jagiello@t-mobile.pl>2023-04-19 09:58:02 +0000
commit6e88d548362b32a15a094fdf8d83f082107c7962 (patch)
tree8603bba306091d8a323ac4ed32920bc075998af5 /test/security/check_versions/pyproject.toml
parentc57b24365c08afe394e52808d55e9b70ac878205 (diff)
Fix security versions script
That script was usused on security versions tests, so I updated it with the latest changes from repo which was really used, created needed files and after we merge it we could use that on security tests. Issue-ID: TEST-394 Signed-off-by: Michal Jagiello <michal.jagiello@t-mobile.pl> Change-Id: I8e5daa7d43e2723bbe3308cf85b1cae2b2f587ad
Diffstat (limited to 'test/security/check_versions/pyproject.toml')
-rw-r--r--test/security/check_versions/pyproject.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/test/security/check_versions/pyproject.toml b/test/security/check_versions/pyproject.toml
new file mode 100644
index 000000000..a9b5c540e
--- /dev/null
+++ b/test/security/check_versions/pyproject.toml
@@ -0,0 +1,21 @@
+[project]
+name = "check_versions"
+readme = "README.md"
+version = "1.0"
+requires-python = ">=3.7"
+dependencies = [
+ "kubernetes",
+ "jinja2",
+ "xtesting",
+ "tabulate",
+ "cerberus",
+ "packaging",
+ "wget"
+]
+
+[build-system]
+requires = ["setuptools"]
+build-backend = "setuptools.build_meta"
+
+[project.entry-points."xtesting.testcase"]
+versions = "versions.k8s_bin_versions_inspector_test_case:Inspector"