aboutsummaryrefslogtreecommitdiffstats
path: root/test/onaptests_bench/setup.py
diff options
context:
space:
mode:
authorMichal Jagiello <michal.jagiello@t-mobile.pl>2022-11-22 10:57:56 +0000
committerMichal Jagiello <michal.jagiello@t-mobile.pl>2022-11-25 10:10:10 +0000
commit63c7edc8fe7640201f4bb6394f7675eb0e19cde4 (patch)
tree9f06c8e4e42850fe0e28f0d9b8ab6073edc062f0 /test/onaptests_bench/setup.py
parent122d630f1703c51b73676ecf0c1622fd3f882d78 (diff)
Add onaptests_bench into integration project repository
Migrate ONAP GitLab project into integration ONAP project Issue-ID: INT-2150 Signed-off-by: Michal Jagiello <michal.jagiello@t-mobile.pl> Change-Id: I5748c47931c8cf37a2fc88d89e117445d6987010
Diffstat (limited to 'test/onaptests_bench/setup.py')
-rw-r--r--test/onaptests_bench/setup.py25
1 files changed, 25 insertions, 0 deletions
diff --git a/test/onaptests_bench/setup.py b/test/onaptests_bench/setup.py
new file mode 100644
index 000000000..0dea62494
--- /dev/null
+++ b/test/onaptests_bench/setup.py
@@ -0,0 +1,25 @@
+#!/usr/bin/env python3
+
+# ============LICENSE_START=======================================================
+# Copyright (C) 2022 Orange, Ltd.
+# ================================================================================
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+# SPDX-License-Identifier: Apache-2.0
+# ============LICENSE_END=========================================================
+
+import setuptools
+setuptools.setup(
+ setup_requires=['pbr', 'setuptools'],
+ pbr=True,
+ include_package_data=True)