summaryrefslogtreecommitdiffstats
path: root/docker/setup.py
diff options
context:
space:
mode:
authorMiroslav Los <miroslav.los@pantheon.tech>2019-11-26 14:20:36 +0100
committerMiroslav Los <miroslav.los@pantheon.tech>2019-11-26 19:24:24 +0100
commit01a60ff23b979eb676658713748598ba4892163a (patch)
tree1fb1b260c3723ddc42f047796db6b1928171b48c /docker/setup.py
parent77e27adeab5ff155b690f2e058c06f0a7812e225 (diff)
Support python3 in all plugins
Unify tox/requirements/setup.py requirement specifications. Do not set upper version limits if possible. Drop uuid as dependency included with standard library. Drop import of unmaintained cloudify_importer without python3 version. Use PEP 508 URLs in requirements for non-PyPI (github) releases. Use cloudify-common 5 release; pre-release package for python3. Rewrite uses of map with loops/comprehensions. Signed-off-by: Miroslav Los <miroslav.los@pantheon.tech> Issue-ID: DCAEGEN2-1956 Change-Id: I7b3ceb97a628e3af5bda3178d182f4207069e86d
Diffstat (limited to 'docker/setup.py')
-rw-r--r--docker/setup.py9
1 files changed, 5 insertions, 4 deletions
diff --git a/docker/setup.py b/docker/setup.py
index d301c49..8cb99b6 100644
--- a/docker/setup.py
+++ b/docker/setup.py
@@ -2,6 +2,7 @@
# org.onap.dcae
# ================================================================================
# Copyright (c) 2017-2018 AT&T Intellectual Property. All rights reserved.
+# Copyright (c) 2019 Pantheon.tech. All rights reserved.
# ================================================================================
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -29,9 +30,9 @@ setup(
packages=['dockerplugin'],
zip_safe=False,
install_requires=[
- "python-consul>=0.6.0,<1.0.0",
- "onap-dcae-dockering>=1.0.0,<2.0.0",
- "uuid==1.30",
- "onap-dcae-dcaepolicy-lib>=2.4.1,<3.0.0"
+ 'python-consul>=0.6.0',
+ 'onap-dcae-dockering>=1.4.0',
+ 'onap-dcae-dcaepolicy-lib>=2.4.1',
+ 'cloudify-common>=5.0.0',
]
)