aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJack Lucas <jflos@sonoris.net>2023-11-15 12:10:36 -0500
committerJack Lucas <jflos@sonoris.net>2023-12-07 13:50:55 -0500
commitbca2314b1351eccaf25d573fa973351a35b43e24 (patch)
treeca59049d2868e5a26a8d7840c3b4d7a0516737db /setup.py
parent5d4f1f1e8248116325164fb7aa3d8058fcd9b037 (diff)
[SNMPTRAP] Use latest cbs library2.0.8
Update to use latest cbs library (2.2.1) in requirements.txt. Pin pyasn1 library to 0.4.8. Later versions are incompatible with the (no longer maintained) pysnmp library. Pin python version to 3.8.x in Dockerfile. Fix EXPOSE syntax in Dockerfile. Issue-ID: DCAEGEN2-3409 Change-Id: I34248376d7c4c2fefa97cee51fc4ff341000375b Signed-off-by: Jack Lucas <jflos@sonoris.net>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 0fb95b0..abac4f3 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,7 @@
# ============LICENSE_START=======================================================
# Copyright (c) 2017-2022 AT&T Intellectual Property. All rights reserved.
# Copyright (c) 2021 Deutsche Telekom. All rights reserved.
+# Copyright (c) 2023 J. F. Lucas. All rights reserved.
# ================================================================================
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -25,9 +26,9 @@ from setuptools import setup, find_packages
setup(
name="snmptrap",
description="snmp trap receiver for ONAP docker image",
- version="2.0.7",
+ version="2.0.8",
packages=find_packages(),
- install_requires=["pysnmp==4.4.12", "requests==2.18.3", "onap_dcae_cbs_docker_client==2.2.1", "pyyaml"],
+ install_requires=["pysnmp==4.4.12", "pyasn1==0.4.8", "requests==2.18.3", "onap_dcae_cbs_docker_client==2.2.1", "pyyaml"],
author="Dave L",
author_email="dl3158@att.com",
license="Apache 2",