aboutsummaryrefslogtreecommitdiffstats
path: root/pom.xml
diff options
context:
space:
mode:
authorLusheng Ji <lji@research.att.com>2018-03-28 02:39:54 -0400
committerLusheng Ji <lji@research.att.com>2018-03-28 22:43:23 +0000
commit1ee2859001e6f5dd687a455672e88f2e73a56463 (patch)
tree59932099581564428343acf23ed5e732ece7c339 /pom.xml
parent339ca1c5d3c9f138a13ae82c181b001df43645eb (diff)
Fix SONAR reporting
Issue-ID: DCAEGEN2-206 Change-Id: If391162de76fae09fca8d464991c8889c51c2590 Signed-off-by: Lusheng Ji <lji@research.att.com> Signed-off-by: Ladue, David (dl3158) <dl3158@att.com>
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml12
1 files changed, 2 insertions, 10 deletions
diff --git a/pom.xml b/pom.xml
index 5ce191a..03bb772 100644
--- a/pom.xml
+++ b/pom.xml
@@ -36,20 +36,12 @@ ECOMP is a trademark and service mark of AT&T Intellectual Property.
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<sonar.skip>false</sonar.skip>
<sonar.sources>.</sonar.sources>
- <!-- customize the SONARQUBE URL -->
- <!-- sonar.host.url>http://localhost:9000</sonar.host.url -->
- <!-- below are language dependent -->
- <!-- for Python -->
+ <sonar.junit.reportsPath>xunit-results.xml</sonar.junit.reportsPath>
+ <sonar.python.coverage.reportPath>coverage.xml</sonar.python.coverage.reportPath>
<sonar.language>py</sonar.language>
<sonar.pluginName>Python</sonar.pluginName>
<sonar.inclusions>**/*.py</sonar.inclusions>
<sonar.exclusions>target/**,tests/**,setup.py,**/__init__.py</sonar.exclusions>
- <!-- for JavaScaript -->
- <!--
- <sonar.language>js</sonar.language>
- <sonar.pluginName>JS</sonar.pluginName>
- <sonar.inclusions>**/*.js</sonar.inclusions>
- -->
</properties>
<build>
<finalName>${project.artifactId}-${project.version}</finalName>