summaryrefslogtreecommitdiffstats
path: root/helm/setup.py
diff options
context:
space:
mode:
authorDan Timoney <dtimoney@att.com>2020-02-20 21:14:26 +0000
committerGerrit Code Review <gerrit@onap.org>2020-02-20 21:14:26 +0000
commit6a407a45c77662a42160462c8fa69261f3fc76b3 (patch)
tree8978922b2a24285eacd21e4afcc4cea5f3bc42f3 /helm/setup.py
parent87d14cfc2cdcdfecbc75396d5347eae295bfb570 (diff)
parent9b7e81e78c70514aa123482610e274869b6ba137 (diff)
Merge "Support python3 in all plugins"
Diffstat (limited to 'helm/setup.py')
-rw-r--r--helm/setup.py13
1 files changed, 7 insertions, 6 deletions
diff --git a/helm/setup.py b/helm/setup.py
index a0b17ef..ff84d0d 100644
--- a/helm/setup.py
+++ b/helm/setup.py
@@ -1,6 +1,7 @@
# ============LICENSE_START==========================================
# ===================================================================
# Copyright (c) 2018 AT&T
+# Copyright (c) 2020 Pantheon.tech. All rights reserved.
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -24,7 +25,7 @@ setup(
# Do not use underscores in the plugin name.
name='helm',
- version='4.0.2',
+ version='4.1.0',
author='Nicolas Hu(AT&T)',
author_email='jh245g@att.com',
description='This plugin will install/uninstall/upgrade/rollback helm '
@@ -36,12 +37,12 @@ setup(
license='LICENSE',
zip_safe=False,
install_requires=[
- # Necessary dependency for developing plugins, do not remove!
'pyyaml>=3.12',
- "cloudify-plugins-common>=4.1.1"
+ # The package specified by requirements would be replaced with 5.0.5.1+
+ # when this package is installed. That currently breaks on python3.
+ #'cloudify-common>=5.0.5',
],
test_requires=[
- "cloudify-dsl-parser>=4.1.1"
- "nose"
- ]
+ 'nose',
+ ],
)