summaryrefslogtreecommitdiffstats
path: root/helm/setup.py
diff options
context:
space:
mode:
authorMiroslav Los <miroslav.los@pantheon.tech>2019-11-14 17:36:44 +0100
committerMiroslav Los <miroslav.los@pantheon.tech>2020-02-14 17:34:04 +0100
commit9b7e81e78c70514aa123482610e274869b6ba137 (patch)
treee2e44b515d518825db9240a5e4a8fe2efe0b3126 /helm/setup.py
parent4daa9d9a30306cfa6d25999cdc992d886fa405a8 (diff)
Support python3 in all plugins
Unify tox/requirements/setup.py requirement specifications. Use cloudify-common 5.0.5 release. For helm, use a dev cloudify-common build with better python3 code. Use PEP 508 URLs in requirements for the non-PyPI (github) release. Fix mixed indentation and trailing whitespace. Signed-off-by: Miroslav Los <miroslav.los@pantheon.tech> Issue-ID: CCSDK-1931 Change-Id: I607957d9e2c299121785f3f02420c6038966a200
Diffstat (limited to 'helm/setup.py')
-rw-r--r--helm/setup.py13
1 files changed, 7 insertions, 6 deletions
diff --git a/helm/setup.py b/helm/setup.py
index a0b17ef..ff84d0d 100644
--- a/helm/setup.py
+++ b/helm/setup.py
@@ -1,6 +1,7 @@
# ============LICENSE_START==========================================
# ===================================================================
# Copyright (c) 2018 AT&T
+# Copyright (c) 2020 Pantheon.tech. All rights reserved.
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -24,7 +25,7 @@ setup(
# Do not use underscores in the plugin name.
name='helm',
- version='4.0.2',
+ version='4.1.0',
author='Nicolas Hu(AT&T)',
author_email='jh245g@att.com',
description='This plugin will install/uninstall/upgrade/rollback helm '
@@ -36,12 +37,12 @@ setup(
license='LICENSE',
zip_safe=False,
install_requires=[
- # Necessary dependency for developing plugins, do not remove!
'pyyaml>=3.12',
- "cloudify-plugins-common>=4.1.1"
+ # The package specified by requirements would be replaced with 5.0.5.1+
+ # when this package is installed. That currently breaks on python3.
+ #'cloudify-common>=5.0.5',
],
test_requires=[
- "cloudify-dsl-parser>=4.1.1"
- "nose"
- ]
+ 'nose',
+ ],
)