summaryrefslogtreecommitdiffstats
path: root/veslibrary/ves_cpplibrary/src/lib/encode/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'veslibrary/ves_cpplibrary/src/lib/encode/CMakeLists.txt')
-rwxr-xr-xveslibrary/ves_cpplibrary/src/lib/encode/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/veslibrary/ves_cpplibrary/src/lib/encode/CMakeLists.txt b/veslibrary/ves_cpplibrary/src/lib/encode/CMakeLists.txt
new file mode 100755
index 0000000..771677e
--- /dev/null
+++ b/veslibrary/ves_cpplibrary/src/lib/encode/CMakeLists.txt
@@ -0,0 +1,21 @@
+aux_source_directory(../common LOG_SRCS)
+aux_source_directory(. ENCODE_SRCS)
+
+find_package(nlohmann_json REQUIRED)
+find_package(spdlog REQUIRED)
+
+include_directories(include)
+
+add_library(xencode SHARED ${LOG_SRCS} ${ENCODE_SRCS})
+
+file(GLOB HDRS "include/*.h")
+
+install(FILES ${HDRS}
+ DESTINATION "include/xvesagent/xencode"
+)
+install(FILES ../../cmake/xencodeConfig.cmake
+ DESTINATION "lib/cmake/xencode"
+)
+INSTALL(TARGETS xencode
+ LIBRARY DESTINATION lib
+)