summaryrefslogtreecommitdiffstats
path: root/csarvalidation/python/setup.py
diff options
context:
space:
mode:
authorBartosz Gardziejewski <bartosz.gardziejewski@nokia.com>2020-10-21 10:34:42 +0200
committerBartosz Gardziejewski <bartosz.gardziejewski@nokia.com>2020-12-01 14:22:29 +0100
commit97f2131b263b4beed8fe4b2dd3c07b44edbac396 (patch)
tree004957710ff2cea79c011efea093e8838849ac95 /csarvalidation/python/setup.py
parent35d4e259c80c9edeb362de0af9bd77bd3f4412b0 (diff)
Add python script to generate table with active validation rules.
Signed-off-by: Bartosz Gardziejewski <bartosz.gardziejewski@nokia.com> Change-Id: I4c944fe6c5bd3cb7f8807d954cc85ad16743841b Issue-ID: VNFSDK-696
Diffstat (limited to 'csarvalidation/python/setup.py')
-rw-r--r--csarvalidation/python/setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/csarvalidation/python/setup.py b/csarvalidation/python/setup.py
new file mode 100644
index 0000000..060d45c
--- /dev/null
+++ b/csarvalidation/python/setup.py
@@ -0,0 +1,30 @@
+# ============LICENSE_START====================================
+# vnfsdk-validation
+# =========================================================
+# Copyright (C) 2020 Nokia. All rights reserved.
+# =========================================================
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+# ============LICENSE_END=====================================
+
+from setuptools import setup
+
+with open('requirements.txt') as f:
+ required = f.read().splitlines()
+
+setup(
+ name='Active rules table generator',
+ version='1.0',
+ description='This project allow generation of tables containing rules that are active for given vnfsdk/validation release.',
+ packages=['main.validation'],
+ install_requires=required
+)