aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorLianhao Lu <lianhao.lu@intel.com>2017-08-01 10:49:31 +0800
committerLianhao Lu <lianhao.lu@intel.com>2017-08-01 10:52:19 +0800
commit9b2c52b958acf3e104259f79db4df8de61910630 (patch)
tree2548c6642b30737e8da83435f3f1f1c100f811b8 /setup.py
parent84febebd8e2c8084dc1034f0c780414b91057e19 (diff)
Resolve the upstream aria dependency issues
The upstream arai has been accepted into apache foundation and the pacakge name and interface name have been changed. Here we adopt these upstream changes accordingly. Also we drop conflicting package dependency requirements which are already included in the upstream aria. Change-Id: I9befbe695cc6edc93029f15bbcee3bfe37099d40 Issue-ID: VNFSDK-61 Signed-off-by: Lianhao Lu <lianhao.lu@intel.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 3 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index ae350cb..53c7f1a 100644
--- a/setup.py
+++ b/setup.py
@@ -64,14 +64,12 @@ setup(
},
# Please make sure this is in sync with src/aria/requirements.txt
install_requires=[
- 'ruamel.yaml==0.12.14',
- 'requests',
+ 'ruamel.yaml<0.12.0,>=0.11.12',
+ 'requests<2.14.0,>=2.3.0',
'logging',
'clint==0.5.1',
'CacheControl[filecache]==0.11.6',
'lockfile',
'Jinja2==2.8',
- 'shortuuid==0.4.3',
- 'jsonpickle',
- 'aria == 0.1'])
+ 'apache-ariatosca==0.1.1'])