summaryrefslogtreecommitdiffstats
path: root/pom.xml
diff options
context:
space:
mode:
authorying.yunlong <ying.yunlong@zte.com.cn>2018-03-03 14:18:41 +0800
committerying.yunlong <ying.yunlong@zte.com.cn>2018-03-03 14:18:41 +0800
commitd8c5efec77c54f6354a88cc6350ff161f72e6676 (patch)
tree75f92ba7ec57f2d75432703512af4046e6e0545e /pom.xml
parent81a45d4f590c92aefe4680fd8ce4496419686a3d (diff)
Fix vfc-vnfmgr sonar job failure
Change-Id: Ifc946e9b2868f088fefbfe4c5563320091804651 Issue-ID: VFC-781 Signed-off-by: ying.yunlong <ying.yunlong@zte.com.cn>
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml83
1 files changed, 0 insertions, 83 deletions
diff --git a/pom.xml b/pom.xml
index a3280e8..9793c19 100644
--- a/pom.xml
+++ b/pom.xml
@@ -26,91 +26,8 @@
<version>1.1.0-SNAPSHOT</version>
<packaging>pom</packaging>
<name>vfc-gvnfm-vnfmgr</name>
- <properties>
- <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
- <sonar.sources>.</sonar.sources>
- <sonar.junit.reportsPath>xunit-results.xml</sonar.junit.reportsPath>
- <sonar.python.coverage.reportPath>coverage.xml</sonar.python.coverage.reportPath>
- <sonar.language>py</sonar.language>
- <sonar.pluginname>python</sonar.pluginname>
- <sonar.inclusions>**/**.py</sonar.inclusions>
- <sonar.exclusions>**/tests/**.py,**/test*.py,**/__init__.py,setup.py</sonar.exclusions>
- </properties>
<description>vfc gvnfm vnfmgr</description>
<modules>
<module>mgr</module>
</modules>
- <build>
- <pluginManagement>
- <plugins>
- <plugin>
- <groupId>org.codehaus.mojo</groupId>
- <artifactId>exec-maven-plugin</artifactId>
- <version>1.2.1</version>
- <configuration>
- <executable>${session.executionRootDirectory}/mvn-phase-script.sh</executable>
- <environmentVariables>
- <!-- make mvn properties as env for our script -->
- <MVN_PROJECT_GROUPID>${project.groupId}</MVN_PROJECT_GROUPID>
- <MVN_PROJECT_ARTIFACTID>${project.artifactId}</MVN_PROJECT_ARTIFACTID>
- <MVN_PROJECT_VERSION>${project.version}</MVN_PROJECT_VERSION>
- </environmentVariables>
- </configuration>
- </plugin>
- </plugins>
- </pluginManagement>
- <plugins>
- <plugin>
- <groupId>org.codehaus.mojo</groupId>
- <artifactId>exec-maven-plugin</artifactId>
- <version>1.2.1</version>
- <executions>
- <execution>
- <id>clean phase script</id>
- <phase>clean</phase>
- <goals>
- <goal>exec</goal>
- </goals>
- <configuration>
- <arguments>
- <argument>__</argument>
- <argument>clean</argument>
- </arguments>
- </configuration>
- </execution>
- <execution>
- <id>test script</id>
- <phase>test</phase>
- <goals>
- <goal>exec</goal>
- </goals>
- <configuration>
- <arguments>
- <argument>__</argument>
- <argument>test</argument>
- </arguments>
- </configuration>
- </execution>
- </executions>
- </plugin>
- <plugin>
- <artifactId>maven-assembly-plugin</artifactId>
- <configuration>
- <appendAssemblyId>false</appendAssemblyId>
- <descriptors>
- <descriptor>assembly.xml</descriptor>
- </descriptors>
- </configuration>
- <executions>
- <execution>
- <id>make-assembly</id>
- <phase>package</phase>
- <goals>
- <goal>single</goal>
- </goals>
- </execution>
- </executions>
- </plugin>
- </plugins>
- </build>
</project>