summaryrefslogtreecommitdiffstats
path: root/robotframework-onap/setup.py
diff options
context:
space:
mode:
authorDR695H <dr695h@att.com>2019-05-04 15:51:36 -0400
committerDR695H <dr695h@att.com>2019-05-04 16:33:51 -0400
commit158df8f73cb2988031cd408939681d3ade443b2f (patch)
treeaaa0faca916a105adef1eb734d3e7dd528cfb7a3 /robotframework-onap/setup.py
parent8ad85420e45ffeafb536de55b31ad68c0d03c986 (diff)
fix vcpeutils
removed relative imports and using the preferred method of importing. use the open instead of file method to get files use the new pyaml method that specifies the loader use builtins.basestring for unicode and nonunicode comparison use the correct method to call the robot framework logger warn adding in unit tests for things to make sure they work Change-Id: I15da74ff66988ef2610ada3ae21a1c6104c26c35 Issue-ID: INT-1061 Signed-off-by: DR695H <dr695h@att.com>
Diffstat (limited to 'robotframework-onap/setup.py')
-rw-r--r--robotframework-onap/setup.py15
1 files changed, 11 insertions, 4 deletions
diff --git a/robotframework-onap/setup.py b/robotframework-onap/setup.py
index 969fe9d..2307375 100644
--- a/robotframework-onap/setup.py
+++ b/robotframework-onap/setup.py
@@ -33,12 +33,18 @@ setup(
'robotframework',
'deepdiff',
'Jinja2',
- 'urllib3',
+ # 'urllib3', # requests gets upset if this is specified since they only work with a very
+ # narrow range of urlib3. if for some reason we remove requests, readd this back in
'six',
- 'requests'
+ 'requests',
+ 'future'
], # what we need
packages=['eteutils', 'loadtest', 'vcpeutils'], # The name of your scripts package
- package_dir={'eteutils': 'eteutils', 'loadtest': 'loadtest', 'vcpeutils':'vcpeutils'}, # The location of your scipts package
+ package_dir={
+ 'eteutils': 'eteutils',
+ 'loadtest': 'loadtest',
+ 'vcpeutils': 'vcpeutils'
+ }, # The location of your scipts package
classifiers=[
'Development Status :: 4 - Beta',
'Intended Audience :: Developers',
@@ -48,5 +54,6 @@ setup(
'Framework :: Robot Framework',
'Framework :: Robot Framework :: Library',
'License :: OSI Approved :: Apache Software License'
- ]
+ ],
+ test_suite="tests.runner"
)