aboutsummaryrefslogtreecommitdiffstats
path: root/packages/arquillian-unit-tests/pom.xml
diff options
context:
space:
mode:
authorxg353y <xg353y@intl.att.com>2017-02-14 11:44:27 +0100
committerXue Gao <xg353y@intl.att.com>2017-02-14 14:45:29 +0000
commit2136b61fb32af1ab519334bba54056faf450bb5b (patch)
treedb5bb219bab554e4ce824135366a20c5db0aab8a /packages/arquillian-unit-tests/pom.xml
parent04bf14bf259ed8b1ddb50d01f4f0084253cb448b (diff)
Update SoapUI tests for APIH Infra
Adding more failure test cases in the APIH Infra SoapUI file. Update the necessarily file to expose arquillian mariadb port and download mariadb driver so that it could be used in SoapUI test cases. Change-Id: I9c3028128530878b432b521aebd0993f1c9e7dd5 Signed-off-by: xg353y <xg353y@intl.att.com>
Diffstat (limited to 'packages/arquillian-unit-tests/pom.xml')
-rw-r--r--packages/arquillian-unit-tests/pom.xml82
1 files changed, 41 insertions, 41 deletions
diff --git a/packages/arquillian-unit-tests/pom.xml b/packages/arquillian-unit-tests/pom.xml
index 7468f45f63..7302d0d058 100644
--- a/packages/arquillian-unit-tests/pom.xml
+++ b/packages/arquillian-unit-tests/pom.xml
@@ -12,7 +12,7 @@
<artifactId>arquillian-unit-tests</artifactId>
<packaging>jar</packaging>
-
+
<profiles>
<profile>
<id>default-tests</id>
@@ -25,10 +25,10 @@
<mso.project.version>${project.version}</mso.project.version>
</properties>
</profile>
-
+
</profiles>
-
-
+
+
<dependencyManagement>
<dependencies>
<dependency>
@@ -38,19 +38,19 @@
<scope>import</scope>
<type>pom</type>
</dependency>
-
+
<dependency>
<groupId>org.jboss.spec</groupId>
<artifactId>jboss-javaee-6.0</artifactId>
<version>3.0.2.Final</version>
<type>pom</type>
<scope>import</scope>
-
+
</dependency>
-
+
</dependencies>
-
-
+
+
</dependencyManagement>
@@ -82,28 +82,28 @@
<version>7.2.0.Final</version>
<scope>test</scope>
</dependency>-->
-
+
<dependency>
<groupId>org.wildfly.arquillian</groupId>
<artifactId>wildfly-arquillian-container-remote</artifactId>
<version>1.1.0.Final</version>
<scope>test</scope>
</dependency>
-
+
<dependency>
<groupId>org.jboss.remoting</groupId>
<artifactId>jboss-remoting</artifactId>
<version>4.0.9.Final</version>
<scope>test</scope>
</dependency>
-
+
<dependency>
<groupId>org.jboss.logging</groupId>
<artifactId>jboss-logging</artifactId>
<version>3.2.1.Final</version>
<scope>test</scope>
</dependency>
-
+
<dependency>
<groupId>org.jboss.arquillian.protocol</groupId>
<artifactId>arquillian-protocol-servlet</artifactId>
@@ -117,8 +117,8 @@
<scope>runtime</scope>
<type>pom</type>
</dependency>
-
- <!-- FOR DOCKER CONTROLLED BY ARQUILLIAN-->
+
+ <!-- FOR DOCKER CONTROLLED BY ARQUILLIAN-->
<dependency>
<groupId>org.arquillian.cube</groupId>
<artifactId>arquillian-cube-openshift-parent</artifactId>
@@ -132,14 +132,14 @@
<version>1.0.0.Alpha15</version>
<scope>test</scope>
</dependency>
-
+
<!-- <dependency>
<groupId>org.eu.ingwar.tools</groupId>
<artifactId>arquillian-suite-extension</artifactId>
<version>1.1.1</version>
<scope>test</scope>
</dependency> -->
-
+
<!-- For testing -->
@@ -193,7 +193,7 @@
</exclusion>
</exclusions>
</dependency>
-
+
<dependency>
<groupId>commons-codec</groupId>
<artifactId>commons-codec</artifactId>
@@ -201,26 +201,26 @@
<type>jar</type>
<scope>test</scope>
</dependency>
-
+
<dependency>
<groupId>org.seleniumhq.selenium</groupId>
<artifactId>selenium-java</artifactId>
- <version>2.45.0</version>
- <scope>test</scope>
- </dependency>
+ <version>2.45.0</version>
+ <scope>test</scope>
+ </dependency>
<dependency>
<groupId>org.seleniumhq.selenium</groupId>
<artifactId>selenium-firefox-driver</artifactId>
<version>2.45.0</version>
<scope>test</scope>
- </dependency>
+ </dependency>
<dependency>
<groupId>org.seleniumhq.selenium</groupId>
<artifactId>selenium-server</artifactId>
- <version>2.45.0</version>
- <scope>test</scope>
+ <version>2.45.0</version>
+ <scope>test</scope>
</dependency>
-
+
<dependency>
<groupId>org.apache.httpcomponents</groupId>
<artifactId>httpclient</artifactId>
@@ -229,7 +229,7 @@
<groupId>org.apache.httpcomponents</groupId>
<artifactId>httpcore</artifactId>
</dependency>
-
+
<dependency>
<groupId>org.openecomp.mso</groupId>
<artifactId>asdc-controller</artifactId>
@@ -237,7 +237,7 @@
<scope>test</scope>
<classifier>classes</classifier>
</dependency>
-
+
<!-- <dependency>
<groupId>org.openecomp.mso.adapters</groupId>
<artifactId>mso-appc-adapter</artifactId>
@@ -245,21 +245,21 @@
<scope>test</scope>
<classifier>classes</classifier>
</dependency> -->
-
+
<dependency>
<groupId>org.mockito</groupId>
<artifactId>mockito-all</artifactId>
<version>1.10.19</version>
<scope>test</scope>
</dependency>
-
+
<dependency>
<groupId>org.openecomp.sdc</groupId>
<artifactId>sdc-distribution-client</artifactId>
<version>0.9.0</version>
<scope>test</scope>
</dependency>
-
+
<dependency>
<groupId>org.openecomp.mso</groupId>
<artifactId>mso-catalog-db</artifactId>
@@ -271,7 +271,7 @@
<groupId>org.apache.jmeter</groupId>
<artifactId>ApacheJMeter_core</artifactId>
<version>2.13</version>
-
+
<scope>test</scope>
<exclusions>
<exclusion>
@@ -284,12 +284,12 @@
</exclusion>
</exclusions>
</dependency>
-
+
<dependency>
<groupId>org.apache.jmeter</groupId>
<artifactId>ApacheJMeter_http</artifactId>
<version>2.13</version>
-
+
<scope>test</scope>
<exclusions>
<exclusion>
@@ -302,12 +302,12 @@
</exclusion>
</exclusions>
</dependency>
-
+
<dependency>
<groupId>org.apache.jmeter</groupId>
<artifactId>ApacheJMeter_jdbc</artifactId>
<version>2.13</version>
-
+
<scope>test</scope>
<exclusions>
<exclusion>
@@ -320,7 +320,7 @@
</exclusion>
</exclusions>
</dependency>
-
+
<!-- END FOR JMETER -->
</dependencies>
@@ -347,12 +347,12 @@
project.properties['docker.host.truncated']="127.0.0.1";
project.properties['docker.host']="unix:///var/run/docker.sock"
}
-
+
if ( project.properties['mso.project.version'].endsWith("-SNAPSHOT") ) {
project.properties['mso.version']="latest";
} else {
project.properties['mso.version']=project.properties['mso.project.version'];
- }
+ }
</source>
</configuration>
</execution>
@@ -372,9 +372,9 @@
</goals>
</execution>
</executions>
-
+
<configuration>
- <systemPropertyVariables>
+ <systemPropertyVariables>
<arquillian.launch>${container-to-start}</arquillian.launch>
<target.folder>${project.build.directory}</target.folder>
<docker.url>${docker.host}</docker.url>