aboutsummaryrefslogtreecommitdiffstats
path: root/pom.xml
diff options
context:
space:
mode:
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml31
1 files changed, 29 insertions, 2 deletions
diff --git a/pom.xml b/pom.xml
index 8407634..d45552a 100644
--- a/pom.xml
+++ b/pom.xml
@@ -4,13 +4,20 @@
<groupId>org.openecomp.sdc</groupId>
<artifactId>sdc-pubsub</artifactId>
- <version>1.0.20</version>
+ <version>1.0.21</version>
<packaging>pom</packaging>
<name>SDC Plugin Pubsub</name>
<properties>
<nexus.proxy>https://nexus.onap.org</nexus.proxy>
<staging.profile.id>176c31dfe190a</staging.profile.id>
+
+ <sonar.typescript.node>node</sonar.typescript.node>
+ <sonar.sources>lib</sonar.sources>
+ <sonar.tests>lib</sonar.tests>
+ <sonar.test.inclusions>lib/*.spec.ts</sonar.test.inclusions>
+ <sonar.typescript.lcov.reportPaths>coverage/lcov.info</sonar.typescript.lcov.reportPaths>
+ <sonar.testExecutionReportPaths>coverage/test-report.xml</sonar.testExecutionReportPaths>
</properties>
<build>
@@ -20,7 +27,7 @@
<version>3.1.0</version>
<executions>
<execution>
- <id>clean dist folder and compiled files</id>
+ <id>clean dist and coverage folder and compiled files</id>
<phase>clean</phase>
<goals>
<goal>clean</goal>
@@ -39,6 +46,9 @@
<directory>${basedir}/dist</directory>
</fileset>
<fileset>
+ <directory>${basedir}/coverage</directory>
+ </fileset>
+ <fileset>
<directory>${basedir}/lib</directory>
<includes>
<include>*.d.ts</include>
@@ -91,6 +101,17 @@
</execution>
<execution>
+ <id>npm test</id>
+ <goals>
+ <goal>npm</goal>
+ </goals>
+ <configuration>
+ <arguments>test -- --coverage</arguments>
+ <npmInheritsProxyConfigFromMaven>false</npmInheritsProxyConfigFromMaven>
+ </configuration>
+ </execution>
+
+ <execution>
<id>npm run build</id>
<goals>
<goal>npm</goal>
@@ -101,6 +122,12 @@
</execution>
</executions>
</plugin>
+
+ <plugin>
+ <groupId>org.sonarsource.scanner.maven</groupId>
+ <artifactId>sonar-maven-plugin</artifactId>
+ <version>3.0.2</version>
+ </plugin>
<!-- Staging Plugin -->
<plugin>