aboutsummaryrefslogtreecommitdiffstats
path: root/pom.xml
diff options
context:
space:
mode:
authorIdan Amit <ia096e@intl.att.com>2018-08-26 16:05:19 +0300
committerIdan Amit <ia096e@intl.att.com>2018-08-26 16:05:19 +0300
commitdc5da2d5d61bd20051ee8b5bffa23773ee7d44f3 (patch)
tree76d8c6ce475aea7c4bd8cef9ffc1be955baeec5c /pom.xml
parent138f7d22e0b8a143d45f23f7aecac0380318cafd (diff)
Add tslint report to sdc-pubsub sonar
Added tslint report to sdc-pubsub sonar Fixed all issues raised from tslint report Change-Id: Iac8174b4a72f190c4b607c2d7ee55f7db457b4b5 Issue-ID: SDC-1668 Signed-off-by: Idan Amit <ia096e@intl.att.com>
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml11
1 files changed, 11 insertions, 0 deletions
diff --git a/pom.xml b/pom.xml
index b186789..368de37 100644
--- a/pom.xml
+++ b/pom.xml
@@ -18,6 +18,7 @@
<sonar.tests>lib</sonar.tests>
<sonar.test.inclusions>lib/*.spec.ts</sonar.test.inclusions>
<sonar.typescript.lcov.reportPaths>coverage/lcov.info</sonar.typescript.lcov.reportPaths>
+ <sonar.typescript.tslint.reportPaths>coverage/tslint-report.json</sonar.typescript.tslint.reportPaths>
<sonar.testExecutionReportPaths>coverage/test-report.xml</sonar.testExecutionReportPaths>
</properties>
@@ -113,6 +114,16 @@
</execution>
<execution>
+ <id>npm tslint</id>
+ <goals>
+ <goal>npm</goal>
+ </goals>
+ <configuration>
+ <arguments>run lint</arguments>
+ </configuration>
+ </execution>
+
+ <execution>
<id>npm run build</id>
<goals>
<goal>npm</goal>