Age | Commit message (Collapse) | Author | Files | Lines |
|
Change-Id: I7efbdf7c36907eb10ae5ce4c9d7d4988d7e2d68a
Issue-ID: POLICY-1965
Signed-off-by: Jim Hahn <jrh3@att.com>
|
|
Removed duplicate code in DbDao by refactoring common code
into a new updateIae() method.
Removed duplicate code in IntegrityMonitor by refactoring common code
into a new withinTransaction() method.
Removed duplicate code in StateManagementEntity, StateElement by
replacing with lombok Getter & Setter annotations.
Removed duplicate code in StateManagement by refactoring common code
into new setState() and getState() methods. Also removed
logger.isDebugEnabled() tests.
Added coverage for StateChangeNotifier.
Change-Id: I2e29b836dafc5de569a2267206a6a34105e44021
Issue-ID: POLICY-1791
Signed-off-by: Jim Hahn <jrh3@att.com>
|
|
Used Eclipse Refactor->Extract Method to reduce cyclomatic
complexity.
Flattened nested FpManager class into IntegrityMonitor class.
Changed some strings to StringBuilder, where lots of concatenation
was being done.
Simplified some things by eliminating some try/catch blocks where
an exception can't actually (except may an out-of-memory exception).
Also addressed some sonar issues in the tests (e.g., use "<>" where
appropriate).
Eliminated some assertException methods, replacing them with assertj
methods.
Did not attempt to increase junit coverage.
Change-Id: I311acaffcd87f0cbbf382c06c7fa26177007abd5
Issue-ID: POLICY-1791
Signed-off-by: Jim Hahn <jrh3@att.com>
|
|
Released 1.5.0
Issue-ID: POLICY-1737
Change-Id: I51b1c264d52cab2b2501dce7c5b0e7805d39ad5c
Signed-off-by: Pamela Dragosh <pdragosh@research.att.com>
|
|
Upgrade minor review for El Alto.
Update to policy/parent
Issue-ID: POLICY-1747
Change-Id: I5c54479d7b1e1951e52580c40127177e5f6d389d
Signed-off-by: Pamela Dragosh <pdragosh@research.att.com>
|
|
In prep for next version.
Issue-ID: POLICY-1700
Change-Id: I4dec2414dbd3d0d941bf24e9cd359265d7105371
Signed-off-by: Pamela Dragosh <pdragosh@research.att.com>
|
|
Issue-ID: POLICY-1232
Change-Id: Icb6179ace3f320bdda3da2160afd2d058762ae5e
Signed-off-by: liamfallon <liam.fallon@ericsson.com>
|
|
Issue-ID: POLICY-1213
Change-Id: Id34f28a3f41687993009128940e9ddec69d5b88f
Signed-off-by: ramverma <ram.krishna.verma@ericsson.com>
|
|
Change-Id: I84fd562e7050508a75b4192ba162a09acd938986
Issue-ID: POLICY-1148
Signed-off-by: Jim Hahn <jrh3@att.com>
|
|
Modified the code to use a CurrentTime object for its "time"
operations (e.g., sleep(), currentTimeInMillis()). Modified
junit tests to replace the CurrentTime object with TestTime
objects so they don't actually do any sleeping.
Update license date.
Remove unneeded dependency from pom.
Don't start FpManager thread within its own constructor.
toMillis() should handle -1 as an input.
Fix comment in test base superclass.
Change time units in test base from DAYS to MILLISECONDS.
Change-Id: Id6a4edb1747ca1a683e5d37522872b781294532d
Issue-ID: POLICY-908
Signed-off-by: Jim Hahn <jrh3@att.com>
|
|
Snapshot updated for Casablanca.
Change-Id: Ife941f771b02be68e35fd638adfac78cf2b3ba99
Issue-ID: POLICY-875
Signed-off-by: liamfallon <liam.fallon@ericsson.com>
|
|
These reviews must be merged in order because of layering.
This review should be merged FIRST.
Issue-ID: POLICY-844
Change-Id: I7cf07902c3b2d7766dc64f1c1dd80d91dee18467
Signed-off-by: liamfallon <liam.fallon@ericsson.com>
|
|
These reviews must be merged in order because of layering.
This review should be merged FIRST
Change-Id: If143b2d23487c073fafad8f6208cd8d320ec98e9
Issue-ID: POLICY-798
Signed-off-by: liamfallon <liam.fallon@ericsson.com>
|
|
Issue-ID: POLICY-736
Change-Id: Iccb43b692908ffc35fc0d18da1e967718e3c3519
Signed-off-by: Pamela Dragosh <pdragosh@research.att.com>
|
|
This is the first sweep to organize the dependencies. I did upgrade
the JUnit in this repo to 4.12 as I thought this would be harmless.
Issue-ID: POLICY-626
Change-Id: I4dc120d2d48830b282d9a173ab69cc553a4d5e78
Signed-off-by: Pamela Dragosh <pdragosh@research.att.com>
|
|
Removed "test" from package name.
Refactored tests, creating common IntegrityMonitorTestBase.
Turned log/print statements into assertEquals in StateTransitionTest.
Turned log/print statements into assertEquals in StateManagementTest.
Modified AllSeemsWellTest to use IntegrityMonitorTestBase.
Modified IntegrityMonitorTest to use IntegrityMonitorTestBase.
Added several hooks to IntegrityMonitor to control timers at a
finer granularity.
Added hooks to IntegrityMonitor to control the FPManager thread.
Remove hooks for refresh timer, as property suffices.
Added assertException() and assertNoException() methods to
IntegrityMonitorTestBase, and then replaced most "try/catch" blocks
with calls to those methods.
Updated StateManagement to close EntityManagers.
Modify pom to remove scope from utils dependency.
Fix some comments and remove an unneeded EntityTransaction variable.
Change-Id: Ic0789d26f985a40a35f618343fa4e88aa473b2b3
Issue-ID: POLICY-582
Signed-off-by: Jim Hahn <jrh3@att.com>
|
|
Added utils-test project to policy/common.
Modified integrity-audit and integrity-monitor to use the new
utils-test project to test the Exception subclasses.
Change-Id: If4a27cdb2351b7c49b084dbf287950172fa059cf
Issue-ID: POLICY-582
Signed-off-by: Jim Hahn <jrh3@att.com>
|
|
Bump minor version in preparation for Amsterdam
branching.
Change-Id: Id33c61586582d008ecede4cd31ed6b046a5bafc0
Issue-ID: CIMAN-120
Signed-off-by: Jessica Wagantall <jwagantall@linuxfoundation.org>
|
|
We release 1.1.1, now move up to 1.1.2
Issue-ID: POLICY-436
Change-Id: I5d2c79ac5f7a2561e79a6644785238465180c59c
Signed-off-by: Pamela Dragosh <pdragosh@research.att.com>
|
|
Releasing version 1.1.0 so we need to update to 1.1.1
Issue-ID: POLICY-436
Change-Id: Ie8979e618b49ebd50d0527275cb70cc3824cde1f
Signed-off-by: Pamela Dragosh <pdragosh@research.att.com>
|
|
Change-Id: I3241f5d1f0234043b4dff718eda1ffdc48052276
Signed-off-by: Guo Ruijing <ruijing.guo@intel.com>
Signed-off-by: Pamela Dragosh <pdragosh@research.att.com>
|
|
Change-Id: I33d11e370801ff9d0f21339ccf953d29c872ff09
Signed-off-by: Pamela Dragosh <pdragosh@research.att.com>
|
|
Change-Id: I305363f5296904aea9147717198e0ea8433d4de8
Signed-off-by: Pamela Dragosh <pdragosh@research.att.com>
|
|
Change-Id: Id7332f7611f4247ba7df7a520aa22815275a1b30
Signed-off-by: Pamela Dragosh <pdragosh@research.att.com>
|
|
Change-Id: I61cd29d6d8bf8702c1a66915895b519bf3484afa
Signed-off-by: Pamela Dragosh <pdragosh@research.att.com>
|