summaryrefslogtreecommitdiffstats
path: root/windriver/pom.xml
diff options
context:
space:
mode:
authorYun Huang <yun.huang@windriver.com>2018-03-13 16:39:58 +0800
committerYun Huang <yun.huang@windriver.com>2018-03-13 16:39:58 +0800
commit280526abe4be41d9e66c8d7b9d70d43c6ab61d64 (patch)
tree00069d68ced02b43d622c5c5a23d14dd203c8351 /windriver/pom.xml
parent7636ee407275885ac5227a5633a2050e7ac1fc8f (diff)
Fix sonar coverage issue for windriver
Change-Id: I6ce2f757d7847250e515529c95694c3611c09e97 Issue-ID: MULTICLOUD-171 Signed-off-by: Yun Huang <yun.huang@windriver.com>
Diffstat (limited to 'windriver/pom.xml')
-rw-r--r--windriver/pom.xml53
1 files changed, 52 insertions, 1 deletions
diff --git a/windriver/pom.xml b/windriver/pom.xml
index df960783..57a24869 100644
--- a/windriver/pom.xml
+++ b/windriver/pom.xml
@@ -50,7 +50,58 @@
<sonar.exclusions>tests/*,setup.py</sonar.exclusions>
</properties>
<build>
- <plugins>
+ <pluginManagement>
+ <plugins>
+ <plugin>
+ <groupId>org.codehaus.mojo</groupId>
+ <artifactId>exec-maven-plugin</artifactId>
+ <version>1.2.1</version>
+ <configuration>
+ <executable>${session.executionRootDirectory}/mvn-phase-script.sh</executable>
+ <environmentVariables>
+ <!-- make mvn properties as env for our script -->
+ <MVN_PROJECT_GROUPID>${project.groupId}</MVN_PROJECT_GROUPID>
+ <MVN_PROJECT_ARTIFACTID>${project.artifactId}</MVN_PROJECT_ARTIFACTID>
+ <MVN_PROJECT_VERSION>${project.version}</MVN_PROJECT_VERSION>
+ </environmentVariables>
+ </configuration>
+ </plugin>
+ </plugins>
+ </pluginManagement>
+ <plugins>
+ <plugin>
+ <groupId>org.codehaus.mojo</groupId>
+ <artifactId>exec-maven-plugin</artifactId>
+ <version>1.2.1</version>
+ <executions>
+ <execution>
+ <id>clean phase script</id>
+ <phase>clean</phase>
+ <goals>
+ <goal>exec</goal>
+ </goals>
+ <configuration>
+ <arguments>
+ <argument>__</argument>
+ <argument>clean</argument>
+ </arguments>
+ </configuration>
+ </execution>
+ <execution>
+ <id>test script</id>
+ <phase>test</phase>
+ <goals>
+ <goal>exec</goal>
+ </goals>
+ <configuration>
+ <arguments>
+ <argument>__</argument>
+ <argument>test</argument>
+ </arguments>
+ </configuration>
+ </execution>
+ </executions>
+ </plugin>
<plugin>
<artifactId>maven-assembly-plugin</artifactId>
<configuration>