summaryrefslogtreecommitdiffstats
path: root/newton/setup.py
diff options
context:
space:
mode:
authorBin Yang <bin.yang@windriver.com>2017-12-19 15:54:33 +0800
committerBin Yang <bin.yang@windriver.com>2017-12-19 15:56:59 +0800
commit7330272e07e7bc3b72bf17cc4eb69ea9584697de (patch)
tree723f0291be74f3822e73f6d3c32b1dd0129bf91e /newton/setup.py
parentb9e844e1545719c8b247031686dd98012735041d (diff)
Add pbr as building tool
PBR is a library that helps to build python project through configuration files simplifying the deployment for them. This change adds support for it. Change-Id: I77ac639d9ba2df7122cb6a9cec68ae7551bac89e Issue-ID: MULTICLOUD-83 Signed-off-by: Victor Morales <victor.morales@intel.com> Signed-off-by: Bin Yang <bin.yang@windriver.com>
Diffstat (limited to 'newton/setup.py')
-rw-r--r--newton/setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/newton/setup.py b/newton/setup.py
new file mode 100644
index 00000000..0e04baae
--- /dev/null
+++ b/newton/setup.py
@@ -0,0 +1,21 @@
+# Copyright (c) 2017 Intel Corporation
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
+import setuptools
+
+setuptools.setup(
+ setup_requires=['pbr'],
+ pbr=True)