summaryrefslogtreecommitdiffstats
path: root/newton/pom.xml
diff options
context:
space:
mode:
authorYun Huang <yun.huang@windriver.com>2018-03-14 21:43:25 +0800
committerYun Huang <yun.huang@windriver.com>2018-03-14 21:43:25 +0800
commit7b7d2abafd64f73d49906e2116fec43ccd930246 (patch)
tree8a88174cf96ab0fae49d18f3aa2227796bf2b791 /newton/pom.xml
parent3d8a68fb65f118a3d12f8fdf8fd1e39158cfdb1b (diff)
Fix sonar coverage issue for newton
Change-Id: I14d4b9063528e65e90efa2ea38e155d4b6c2761d Issue-ID: MULTICLOUD-171 Signed-off-by: Yun Huang <yun.huang@windriver.com>
Diffstat (limited to 'newton/pom.xml')
-rw-r--r--newton/pom.xml65
1 files changed, 62 insertions, 3 deletions
diff --git a/newton/pom.xml b/newton/pom.xml
index ba375609..8ba525e3 100644
--- a/newton/pom.xml
+++ b/newton/pom.xml
@@ -27,10 +27,18 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.onap.multicloud.openstack</groupId>
<artifactId>multicloud-openstack-newton</artifactId>
- <version>1.1.1-SNAPSHOT</version>
+ <version>1.1.0-SNAPSHOT</version>
<packaging>pom</packaging>
<name>multicloud/openstack/newton</name>
<description>multicloud for openstack newton</description>
+ <dependencies>
+ <dependency>
+ <groupId>org.onap.multicloud.openstack</groupId>
+ <artifactId>multicloud-openstack-newton</artifactId>
+ <version>1.1.0</version>
+ <type>zip</type>
+ </dependency>
+ </dependencies>
<properties>
<encoding>UTF-8</encoding>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
@@ -42,10 +50,61 @@
<sonar.language>py</sonar.language>
<sonar.pluginName>Python</sonar.pluginName>
<sonar.inclusions>**/*.py</sonar.inclusions>
- <sonar.exclusions>tests/*,setup.py</sonar.exclusions>
+ <sonar.exclusions>**/venv-tox/**,**/.tox/**, **/tests/**,setup.py</sonar.exclusions>
</properties>
<build>
- <plugins>
+ <pluginManagement>
+ <plugins>
+ <plugin>
+ <groupId>org.codehaus.mojo</groupId>
+ <artifactId>exec-maven-plugin</artifactId>
+ <version>1.2.1</version>
+ <configuration>
+ <executable>${session.executionRootDirectory}/mvn-phase-script.sh</executable>
+ <environmentVariables>
+ <!-- make mvn properties as env for our script -->
+ <MVN_PROJECT_GROUPID>${project.groupId}</MVN_PROJECT_GROUPID>
+ <MVN_PROJECT_ARTIFACTID>${project.artifactId}</MVN_PROJECT_ARTIFACTID>
+ <MVN_PROJECT_VERSION>${project.version}</MVN_PROJECT_VERSION>
+ </environmentVariables>
+ </configuration>
+ </plugin>
+ </plugins>
+ </pluginManagement>
+ <plugins>
+ <plugin>
+ <groupId>org.codehaus.mojo</groupId>
+ <artifactId>exec-maven-plugin</artifactId>
+ <version>1.2.1</version>
+ <executions>
+ <execution>
+ <id>clean phase script</id>
+ <phase>clean</phase>
+ <goals>
+ <goal>exec</goal>
+ </goals>
+ <configuration>
+ <arguments>
+ <argument>__</argument>
+ <argument>clean</argument>
+ </arguments>
+ </configuration>
+ </execution>
+ <execution>
+ <id>test script</id>
+ <phase>test</phase>
+ <goals>
+ <goal>exec</goal>
+ </goals>
+ <configuration>
+ <arguments>
+ <argument>__</argument>
+ <argument>test</argument>
+ </arguments>
+ </configuration>
+ </execution>
+ </executions>
+ </plugin>
<plugin>
<artifactId>maven-assembly-plugin</artifactId>
<configuration>