summaryrefslogtreecommitdiffstats
path: root/config/vnflist.spec
diff options
context:
space:
mode:
Diffstat (limited to 'config/vnflist.spec')
-rw-r--r--config/vnflist.spec19
1 files changed, 19 insertions, 0 deletions
diff --git a/config/vnflist.spec b/config/vnflist.spec
new file mode 100644
index 0000000..49c2434
--- /dev/null
+++ b/config/vnflist.spec
@@ -0,0 +1,19 @@
+[
+ // Use https://jolt-demo.appspot.com/#inception to develop/test
+ // any changes to this file
+
+ {
+ // This section converts aai response for GET VNF-API from SDNC
+ // to org.onap.pomba.common.datatypes.VF
+ "operation": "shift",
+ "spec": {
+ "vnfs": {
+ "vnf-list": {
+ "*": {
+ "*": "vnf-list[&1].&"
+ }
+ }
+ }
+ }
+ }
+ ]