summaryrefslogtreecommitdiffstats
path: root/config/sdncgenericresource.spec
diff options
context:
space:
mode:
Diffstat (limited to 'config/sdncgenericresource.spec')
-rw-r--r--config/sdncgenericresource.spec17
1 files changed, 11 insertions, 6 deletions
diff --git a/config/sdncgenericresource.spec b/config/sdncgenericresource.spec
index 518b557..81542a2 100644
--- a/config/sdncgenericresource.spec
+++ b/config/sdncgenericresource.spec
@@ -16,7 +16,8 @@
"service-instance-name": "service.name"
},
"onap-model-information": {
- "model-invariant-uuid": "service.invariantUUID"
+ "model-invariant-uuid": "service.modelInvariantUUID",
+ "model-uuid": "service.modelVersionID"
}
},
"vnfs": {
@@ -25,10 +26,11 @@
"vnf-data": {
"vnf-topology": {
"onap-model-information": {
- "model-uuid": "vnfList[&4].uuid",
- "model-invariant-uuid": "vnfList[&4].invariantUUID"
+ "model-uuid": "vnfList[&4].modelVersionID",
+ "model-invariant-uuid": "vnfList[&4].modelInvariantUUID"
},
"vnf-topology-identifier-structure": {
+ "vnf-id": "vnfList[&4].uuid",
"vnf-type": "vnfList[&4].type",
"vnf-name": "vnfList[&4].name"
},
@@ -51,11 +53,13 @@
"vf-module-data": {
"vf-module-topology": {
"vf-module-topology-identifier": {
+ "vf-module-id": "vnfList[&8].vfModuleList[&4].uuid",
"vf-module-name": "vnfList[&8].vfModuleList[&4].name"
},
"onap-model-information": {
- "model-uuid": "vnfList[&8].vfModuleList[&4].uuid",
- "model-invariant-uuid": "vnfList[&8].vfModuleList[&4].invariantUUID"
+ "model-uuid": "vnfList[&8].vfModuleList[&4].modelVersionID",
+ "model-invariant-uuid": "vnfList[&8].vfModuleList[&4].modelInvariantUUID",
+ "model-customization-uuid": "vnfList[&8].vfModuleList[&4].modelCustomizationUUID"
},
"vf-module-assignments": {
"vms": {
@@ -137,7 +141,8 @@
"network-technology": "networkList[&4].attributeList[2].value"
},
"onap-model-information": {
- "model-invariant-uuid": "networkList[&4].invariantUUID"
+ "model-uuid": "networkList[&4].modelVersionID",
+ "model-invariant-uuid": "networkList[&4].modelInvariantUUID"
}
}
}