aboutsummaryrefslogtreecommitdiffstats
path: root/config/networkdiscovery.spec
diff options
context:
space:
mode:
Diffstat (limited to 'config/networkdiscovery.spec')
-rw-r--r--config/networkdiscovery.spec52
1 files changed, 8 insertions, 44 deletions
diff --git a/config/networkdiscovery.spec b/config/networkdiscovery.spec
index 8da7a87..2cc882c 100644
--- a/config/networkdiscovery.spec
+++ b/config/networkdiscovery.spec
@@ -1,39 +1,6 @@
[
// Use https://jolt-demo.appspot.com/#inception to develop/test
// any changes to this file
-
- {
- // This sections adds nfNamingCode and dataQuality to the json
- // fields returned from service-decomposition that we are
- // interested in
- "operation": "default",
- "spec": {
- "generic-vnfs[]": {
- "*": {
- "vf-modules": {
- "vf-module[]": {
- "*": {}
- }
- },
- "vservers[]": {
- "*": {
- "nfNamingCode": "vserver"
- }
- },
- "l3-networks[]": {
- "*": {
- "type": "l3-network"
- }
- },
- "vnfcList[]": {
- "*": {
- "type": "vnfc"
- }
- }
- }
- }
- }
- },
{
// This section converts the updated json from service-decompostion
// to org.onap.pomba.common.datatypes.ModelContext
@@ -44,24 +11,21 @@
"*": {
"vservers": {
"*": {
- "vserver-id": "vfList[&3].vfModuleList[0].vmList[&1].uuid",
- "nfNamingCode": "vfList[&3].vfModuleList[0].vmList[&1].nfNamingCode"
+ "vserver-id": "vnfList[&3].vfModuleList[0].vmList[&1].uuid"
}
},
"l3-networks": {
"*": {
- "network-id": "vfList[&3].vfModuleList[0].networkList[&1].uuid",
- "type": "vfList[&3].vfModuleList[0].networkList[&1].type"
- },
- "vnfcs": {
- "*": {
- "vnfc-id": "vfList[&2].vnfcList[&1].uuid",
- "type": "vfList[&2].vfModuleList[0].type"
- }
+ "network-id": "vnfList[&3].vfModuleList[0].networkList[&1].uuid"
+ }
+ },
+ "vnfcs": {
+ "*": {
+ "vnfc-id": "vnfList[&3].vnfcList[&1].uuid"
}
}
}
}
}
- }
+ }
]