aboutsummaryrefslogtreecommitdiffstats
path: root/pylog/setup.py
diff options
context:
space:
mode:
authorliangke <lokyse@163.com>2018-02-28 15:22:43 +0800
committerliangke <lokyse@163.com>2018-03-01 12:52:58 +0800
commit15fc9df448221c4d24fe4c097fe5e00b4512f083 (patch)
treef105b65035c8e576249d5e1d781253b181f35862 /pylog/setup.py
parent9379dc6c5bd516a7601a179603de1aeefc5140ec (diff)
Submit python logging library seed code
Change-Id: I4c039a667d7b8c7a257b2d50f94370785100a968 Issue-ID: MULTICLOUD-151 Issue-ID: LOG-161 Signed-off-by: liangke <lokyse@163.com>
Diffstat (limited to 'pylog/setup.py')
-rw-r--r--pylog/setup.py37
1 files changed, 37 insertions, 0 deletions
diff --git a/pylog/setup.py b/pylog/setup.py
new file mode 100644
index 0000000..bcd2347
--- /dev/null
+++ b/pylog/setup.py
@@ -0,0 +1,37 @@
+# Copyright (c) 2018 VMware, Inc.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+
+
+from setuptools import setup, find_packages
+
+setup(
+
+ name='onappylog',
+ keywords=("yaml", "logging", "mdc", "onap"),
+ description='onap python logging library',
+ long_description="python-package onappylog could be used in any python project to record MDC information and reload logging at runtime",
+ version="1.0.5",
+ license="MIT Licence",
+ author='ke liang',
+ author_email="lokyse@163.com",
+ packages=find_packages(),
+ platforms=['all'],
+ install_requires=[
+ "PyYAML>=3.10",
+ "watchdog>=0.8.3"
+ ],
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python :: 2.7'
+ ]
+)