aboutsummaryrefslogtreecommitdiffstats
path: root/infra-healthcheck/setup.py
diff options
context:
space:
mode:
authorMichal Jagiello <michal.jagiello@t-mobile.pl>2023-05-11 14:32:52 +0000
committerMichal Jagiello <michal.jagiello@t-mobile.pl>2023-05-25 20:22:46 +0000
commite9d76d6a00131ee0b1e445074f19a30ab0a330e4 (patch)
tree69fe7c9011d6f071874a8759d273d2500a67ee7c /infra-healthcheck/setup.py
parentc4294c4d2e564083382f4b9fe1e73c74c8252c70 (diff)
[INFRA] Add integration script to run onap-k8s test
Next to Orange use ONAP script to run that test Refactor docker image build to not clone that repo Issue-ID: INT-2226 Signed-off-by: Michal Jagiello <michal.jagiello@t-mobile.pl> Change-Id: If321945c3ce3bca0f66256ba2d05243759817493
Diffstat (limited to 'infra-healthcheck/setup.py')
-rw-r--r--infra-healthcheck/setup.py20
1 files changed, 14 insertions, 6 deletions
diff --git a/infra-healthcheck/setup.py b/infra-healthcheck/setup.py
index 566d844..ee1ecad 100644
--- a/infra-healthcheck/setup.py
+++ b/infra-healthcheck/setup.py
@@ -19,11 +19,19 @@ import setuptools
# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
+
setuptools.setup(
- setup_requires=['pbr>=2.0.0'],
- pbr=True)
+ name="infra_healthcheck",
+ version="1",
+ packages=["infra_healthcheck"],
+ entry_points={
+ "xtesting.testcase": [
+ 'onap_helm = helm_onap_status.status:Status',
+ 'onap_chart = chart_status.status:Status',
+ 'nodeport_ingress = infra_healthcheck.k8stest:OnapSecurityNodePortsIngress',
+ 'nodeport_check_certs = infra_healthcheck.k8stest:OnapSecurityNodePortsCerts',
+ 'internal_check_certs = infra_healthcheck.k8stest:OnapSecurityInternalPortsCerts'
+ ]
+ }
+)