aboutsummaryrefslogtreecommitdiffstats
path: root/simulator-cli/pom.xml
diff options
context:
space:
mode:
Diffstat (limited to 'simulator-cli/pom.xml')
-rw-r--r--simulator-cli/pom.xml69
1 files changed, 69 insertions, 0 deletions
diff --git a/simulator-cli/pom.xml b/simulator-cli/pom.xml
new file mode 100644
index 0000000..60721df
--- /dev/null
+++ b/simulator-cli/pom.xml
@@ -0,0 +1,69 @@
+<?xml version="1.0"?>
+<!--
+================================================================================
+Copyright (c) 2017-2020 AT&T Intellectual Property. All rights reserved.
+Copyright (c) 2020 Pantheon.tech. All rights reserved.
+Copyright (c) 2020-2021 Nokia. All rights reserved.
+Copyright (c) 2020 J. F. Lucas. All rights reserved.
+================================================================================
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
+============LICENSE_END=========================================================
+-->
+<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.onap.integration.simulators.nf-simulator</groupId>
+ <artifactId>nf-simulator</artifactId>
+ <version>1.0.0</version>
+ </parent>
+
+ <groupId>simulator-cli</groupId>
+ <artifactId>simulator-cli</artifactId>
+ <version>1.0.0-SNAPSHOT</version>
+ <name>simulator-cli</name>
+
+ <properties>
+ <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
+ <sonar.sources>.</sonar.sources>
+ <sonar.junit.reportsPath>xunit-results.xml</sonar.junit.reportsPath>
+ <sonar.python.coverage.reportPaths>coverage.xml</sonar.python.coverage.reportPaths>
+ <sonar.language>py</sonar.language>
+ <sonar.pluginName>Python</sonar.pluginName>
+ <sonar.inclusions>./*.py</sonar.inclusions>
+ <sonar.exclusions>tests/*,setup.py</sonar.exclusions>
+ </properties>
+
+ <build>
+ <finalName>${project.artifactId}-${project.version}</finalName>
+ <plugins>
+ <plugin>
+ <groupId>org.codehaus.mojo</groupId>
+ <artifactId>exec-maven-plugin</artifactId>
+ <version>1.2.1</version>
+ <executions>
+ <execution>
+ <configuration>
+ <executable>tox</executable>
+ <workingDirectory>.</workingDirectory>
+ </configuration>
+ <id>python-build</id>
+ <phase>prepare-package</phase>
+ <goals>
+ <goal>exec</goal>
+ </goals>
+ </execution>
+ </executions>
+ </plugin>
+ </plugins>
+ </build>
+</project>