aboutsummaryrefslogtreecommitdiffstats
path: root/simulator-cli/setup.py
diff options
context:
space:
mode:
authorEdyta Krukowska <edyta.krukowska@nokia.com>2021-03-15 13:30:09 +0100
committerEdyta Krukowska <edyta.krukowska@nokia.com>2021-03-15 14:01:32 +0100
commitc4a6e3114d3614e257350f967eeb58517afff06b (patch)
tree2fa2356db5213249e3146f21328cb4ba1a0461d1 /simulator-cli/setup.py
parent78af475bcc9022484b16c7d563c93c0e934ff677 (diff)
Move simulator-ci from pnf-simulator to nf-simulator
Issue-ID: INT-1869 Signed-off-by: Edyta Krukowska <edyta.krukowska@nokia.com> Change-Id: I31ca7d48f4ff9438e28b3637bb98fdd391d14030
Diffstat (limited to 'simulator-cli/setup.py')
-rw-r--r--simulator-cli/setup.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/simulator-cli/setup.py b/simulator-cli/setup.py
new file mode 100644
index 0000000..e311abc
--- /dev/null
+++ b/simulator-cli/setup.py
@@ -0,0 +1,34 @@
+###
+# ============LICENSE_START=======================================================
+# Simulator
+# ================================================================================
+# Copyright (C) 2021 Nokia. All rights reserved.
+# ================================================================================
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+# ============LICENSE_END=========================================================
+###
+
+import setuptools
+
+setuptools.setup(
+ name="nf_simulator_cli",
+ version="5.0.0",
+ description="Command line interface which allows to communicate with NF SIMULATOR",
+ packages=setuptools.find_packages(),
+ data_files=['cli/data/logging.ini'],
+ classifiers=["Programming Language :: Python :: 3"],
+ install_requires=[
+ 'requests==2.20.1',
+ 'websockets==7.0'
+ ]
+)