aboutsummaryrefslogtreecommitdiffstats
path: root/test/mocks/mass-pnf-sim/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'test/mocks/mass-pnf-sim/setup.py')
-rwxr-xr-xtest/mocks/mass-pnf-sim/setup.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/test/mocks/mass-pnf-sim/setup.py b/test/mocks/mass-pnf-sim/setup.py
new file mode 100755
index 000000000..662976b03
--- /dev/null
+++ b/test/mocks/mass-pnf-sim/setup.py
@@ -0,0 +1,36 @@
+#!/usr/bin/env python3
+
+# COPYRIGHT NOTICE STARTS HERE
+#
+# Copyright 2020 Samsung Electronics Co., Ltd.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+# COPYRIGHT NOTICE ENDS HERE
+
+# This file is only meant to be a single source of truth for package
+# dependencies. It's consumed by bin/setup.sh and tox hence shouldn't
+# be run directly for package builds as currently vcpe scripts are not
+# provided as a python package.
+
+import setuptools
+
+# Define MassPnfSim module dependencies below
+setuptools.setup(
+ name="MassPnfSim",
+ install_requires=[
+ 'argparse',
+ 'ipaddress',
+ 'requests'
+ ]
+)