aboutsummaryrefslogtreecommitdiffstats
path: root/test/mocks/ran-nssmf-simulator/setup.py
diff options
context:
space:
mode:
authorEnbo Wang <wangenbo@huawei.com>2020-09-18 11:06:12 +0800
committerEnbo Wang <wangenbo@huawei.com>2020-09-19 17:25:04 +0800
commitb764f221db38dd0d0fb3bad908e5d1329721730d (patch)
tree0a60d0bc8a3f9b6ac0a941a955ba0007fe57cd06 /test/mocks/ran-nssmf-simulator/setup.py
parentedbe50b80ce489b5ef9f30c9cd72f2dbcf2032d9 (diff)
Add an External RAN NSSMF simulator
Change-Id: I770091159dd1f953d8a567ccd2bd7f6d21f27649 Issue-ID: INT-1707 Signed-off-by: Enbo Wang <wangenbo@huawei.com>
Diffstat (limited to 'test/mocks/ran-nssmf-simulator/setup.py')
-rw-r--r--test/mocks/ran-nssmf-simulator/setup.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/test/mocks/ran-nssmf-simulator/setup.py b/test/mocks/ran-nssmf-simulator/setup.py
new file mode 100644
index 000000000..bc6e20f85
--- /dev/null
+++ b/test/mocks/ran-nssmf-simulator/setup.py
@@ -0,0 +1,34 @@
+#! /usr/bin/python3
+
+# ============LICENSE_START=======================================================
+# Copyright (C) 2020 Huawei Technologies Co., Ltd. All rights reserved.
+# ================================================================================
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+# ============LICENSE_END=========================================================
+
+from setuptools import setup, find_packages
+
+setup(
+ name="RanNssmfSimulator",
+ version="0.1.0",
+ description="RAN NSSMF Simulator",
+ license="Apache License, Version 2.0",
+ packages=find_packages(),
+ data_files=[
+ ('RanNssmfSimulator/etc', ['RanNssmfSimulator/etc/auth.json'])
+ ],
+ install_requires=[
+ 'Flask',
+ 'schematics'
+ ]
+)