summaryrefslogtreecommitdiffstats
path: root/python-dcae-policy/setup.py
diff options
context:
space:
mode:
authorAlex Shatov <alexs@att.com>2017-09-12 11:46:25 -0400
committerAlex Shatov <alexs@att.com>2017-09-12 11:46:25 -0400
commit0c209c0c2b6e4bbadf413c048d9c535d3c2d1a0b (patch)
tree0d4b4db47b5d7cc931bb63363fb168bc62c41f4a /python-dcae-policy/setup.py
parenteee6ffd3ab306b38487746ec5f883fee4dde72e9 (diff)
1.0.0 and removed dcae.node.type and policy_get
* moved dcae.node.type and policy_get from lib to dcaepolicy plugin and dcae.node.type * removed dependency on cloudify-plugins-common and requests packages * removed discovery logic since the lib does not talk to policy-handler anymore - happens in the new dcaepolicy plugin now * no more policy_apply_mode per policy node - it is up to component's blueprint to decide how to notify about policy change Change-Id: Ieefc3b5af1166a5c201574144fbf8c399e5ddc15 Issue-Id: DCAEGEN2-62 Signed-off-by: Alex Shatov <alexs@att.com>
Diffstat (limited to 'python-dcae-policy/setup.py')
-rw-r--r--python-dcae-policy/setup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/python-dcae-policy/setup.py b/python-dcae-policy/setup.py
index 1fd4550..5f0c765 100644
--- a/python-dcae-policy/setup.py
+++ b/python-dcae-policy/setup.py
@@ -24,17 +24,15 @@ from setuptools import setup
setup(
name='dcaepolicy',
description='lib of policy decorators to be used by cloudify plugins of dcae controller',
- version="0.0.2",
+ version="1.0.0",
author='Alex Shatov',
email="dcae@lists.openecomp.org",
packages=['dcaepolicy'],
install_requires=[
- "cloudify-plugins-common==3.4",
- "requests>=2.11.0,<3.0.0"
],
keywords='policy dcae controller cloudify plugin',
classifiers=[
- 'Development Status :: 3 - Alpha',
+ 'Development Status :: 4 - Beta',
'Intended Audience :: Developers',
'Programming Language :: Python :: 2.7'
]