aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexander Mazuruk <a.mazuruk@samsung.com>2021-03-26 16:18:03 +0100
committerAlexander Mazuruk <a.mazuruk@samsung.com>2021-04-09 12:22:19 +0200
commit3129229fc850ad8039b2241f389cd5f6fe28f840 (patch)
tree032e8c30e3b54a3f5a3592005cad539aad77be07 /setup.py
parentf811f3c845fdd38ce2ad740be8331d28ddd32945 (diff)
Dependencies update: Wheel, PyYAML, httplib2, HTTPretty
Changelogs of updated pkgs: https://wheel.readthedocs.io/en/stable/news.html https://github.com/yaml/pyyaml/blob/master/CHANGES https://github.com/httplib2/httplib2/blob/master/CHANGELOG https://httpretty.readthedocs.io/en/latest/changelog.html Additionally resolved some warnings reported by tox: - remove unused func from tests that used deprecated python lib. - change collections import to collections.abc Issue-ID: DCAEGEN2-2720 Signed-off-by: Alexander Mazuruk <a.mazuruk@samsung.com> Change-Id: I1dadbe9e6e410bdec1a06ea7c69e49576551218b
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 5 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index f5abfd2..67d7308 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,6 @@
# ============LICENSE_START=======================================================
# Copyright (c) 2017-2018 AT&T Intellectual Property. All rights reserved.
+# Copyright (c) 2021 Samsung Electronics. All rights reserved.
# ================================================================================
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -41,11 +42,11 @@ setup(
"requests==2.18.3",
"onap_dcae_cbs_docker_client==1.0.1",
"six==1.10.0",
-"PyYAML==3.12",
-"httplib2==0.9.2",
-"HTTPretty==0.8.14",
+"PyYAML==3.13",
+"httplib2==0.19.0",
+"HTTPretty==1.0.5",
"pyOpenSSL==17.5.0",
-"Wheel==0.31.0",
+"Wheel==0.36.2",
"psycopg2-binary==2.8.5"
],
author = "Vijay Venkatesh Kumar",