summaryrefslogtreecommitdiffstats
path: root/components/pm-subscription-handler/setup.py
diff options
context:
space:
mode:
authorefiacor <fiachra.corcoran@est.tech>2019-11-06 11:08:54 +0000
committerefiacor <fiachra.corcoran@est.tech>2019-12-02 10:31:56 +0000
commit9b53268341d1022688a431f5a01e38cb26b8f610 (patch)
tree9965ec996fc8e97ab3f3cad9712324c52a2daf9a /components/pm-subscription-handler/setup.py
parenta8a31129d5e32fccdbf123a99043b32077453cdf (diff)
Initial commit for PMSH
Signed-off-by: efiacor <fiachra.corcoran@est.tech> Issue-ID: DCAEGEN2-1837 Change-Id: I3b7d7d379df68f0f5984a3c4e0faa9c8ca0bcdf8
Diffstat (limited to 'components/pm-subscription-handler/setup.py')
-rw-r--r--components/pm-subscription-handler/setup.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/components/pm-subscription-handler/setup.py b/components/pm-subscription-handler/setup.py
new file mode 100644
index 00000000..9012a04c
--- /dev/null
+++ b/components/pm-subscription-handler/setup.py
@@ -0,0 +1,35 @@
+# ============LICENSE_START=======================================================
+# Copyright (C) 2019 Nordix Foundation.
+# ================================================================================
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+# SPDX-License-Identifier: Apache-2.0
+# ============LICENSE_END=========================================================
+
+from setuptools import setup, find_packages
+
+setup(
+ name="pm_subscription_handler",
+ version="1.0.0",
+ packages=find_packages(),
+ author="lego@est.tech",
+ author_email="lego@est.tech",
+ license='Apache 2',
+ description="Service to handle PM subscriptions",
+ url="https://gerrit.onap.org/r/#/admin/projects/dcaegen2/services",
+ python_requires='>=3',
+ install_requires=[
+ "requests==2.22.0",
+ "aiohttp==3.6.2",
+ "onappylog==1.0.9"],
+)