aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Shatov <alexs@att.com>2018-06-14 12:06:42 -0400
committerAlex Shatov <alexs@att.com>2018-06-14 12:06:42 -0400
commitc9ec231483d905f3a391c3985c2c2762344ed5c1 (patch)
treefae12736cb572f07f733fe4a5ffd68e2df21d77e /setup.py
parent83de7401162dc895ae8343a2e43f2c9eb57afb06 (diff)
3.0.0 policy-handler - migrated to python 3.6
- migrated from python 2.7 to 3.6 - brought up the latest versions of dependencies -- Cherrypy 15.0.0, requests 2.18.4, websocket-client 0.48.0 - fixed migration errors -- renamed the standard package Queue to queue -- dict.items() instead of dict.iteritems() -- dict.keys() instead of dict.viewkeys() -- range() instead of xrange() -- subprocess.check_output(..., universal_newlines=True) to get str instead of byte-stream from stdout - cleaned up migration warnings -- super() instead of super(A, self) -- logger.warning() instead of .warn() - moved main() from policy_handler.py to __main__.py - getting the policy_handler version directly from setup.py instead of the env var on init of the audit Change-Id: I0fc4ddc51c08a64f3cfdc5d2f010b1c6a1ae92f0 Signed-off-by: Alex Shatov <alexs@att.com> Issue-ID: DCAEGEN2-515
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 5 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 55ca797..2f9ab6d 100644
--- a/setup.py
+++ b/setup.py
@@ -23,21 +23,19 @@ from setuptools import setup
setup(
name='policyhandler',
description='DCAE-Controller policy-handler to communicate with policy-engine',
- version="2.4.5",
+ version="3.0.0",
author='Alex Shatov',
packages=['policyhandler'],
zip_safe=False,
install_requires=[
- "CherryPy>=10.2.2,<11.0",
+ "CherryPy>=15.0.0,<16.0.0",
"enum34>=1.1.6",
"psutil>=5.4.5,<6.0.0",
- "requests>=2.13.0,<3.0.0",
- "websocket-client>=0.40.0,<1.0.0"
+ "requests>=2.18.4,<3.0.0",
+ "websocket-client>=0.48.0,<1.0.0"
],
keywords='policy dcae controller',
classifiers=[
- 'Development Status :: 4 - Beta',
- 'Intended Audience :: Developers',
- 'Programming Language :: Python :: 2.7'
+ 'Programming Language :: Python :: 3.6'
]
)