aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Shatov <alexs@att.com>2017-10-27 16:56:08 -0400
committerAlex Shatov <alexs@att.com>2017-10-27 16:56:08 -0400
commit81a1b05ebd918c3a8148382661f00f3183894f9a (patch)
treed0fe707fd3e7b8a0f89fa0b3af916fbe29dc69db /setup.py
parent2d452d17a679ac85b7a7eba0da8767d6fafb8e4c (diff)
fixed ClientAuth and Authorization parsing
two formats of ClientAuth and Authorization * Basic <auth> * <auth> Change-Id: I177a86caef6b2a2406277413d5de1972bcf19cfe Issue-Id: DCAEGEN2-128 Signed-off-by: Alex Shatov <alexs@att.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index d39a1c2..85e74ba 100644
--- a/setup.py
+++ b/setup.py
@@ -29,10 +29,10 @@ setup(
packages=['policyhandler'],
zip_safe=False,
install_requires=[
- "CherryPy>=10.2.2",
+ "CherryPy>=10.2.2,<11.0",
"enum34>=1.1.6",
"future>=0.16.0",
- "requests>=2.13.0",
+ "requests>=2.13.0,<3.0.0",
"six>=1.10.0",
"websocket-client>=0.40.0"
],