aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Shatov <alexs@att.com>2017-09-12 13:00:25 -0400
committerAlex Shatov <alexs@att.com>2017-09-12 13:00:25 -0400
commit42a989a6b9b6388947da6fc273728a24c19fa686 (patch)
tree9d1dfc98ddd56fe058c030f9b4b8ce117aa16717 /setup.py
parentfe9c74b9933745144bfd8134bc96fd77fa3291f8 (diff)
1.0.0 and policy API to deployment-handler
* policy API to deployment-handler /policy * removed pycrypto of config - the same way as other apps * simple upload of config to consul - curl * preparation for policy-handler blueprint Change-Id: I424a1ded0795562ea36b5409304cbb8b5a7e8a24 Issue-Id: DCAEGEN2-62 Signed-off-by: Alex Shatov <alexs@att.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 7 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index adfcf98..d39a1c2 100644
--- a/setup.py
+++ b/setup.py
@@ -24,7 +24,7 @@ from setuptools import setup
setup(
name='policyhandler',
description='DCAE-Controller policy-handler to communicate with policy-engine',
- version="0.0.1",
+ version="1.0.0",
author='Alex Shatov',
packages=['policyhandler'],
zip_safe=False,
@@ -32,9 +32,14 @@ setup(
"CherryPy>=10.2.2",
"enum34>=1.1.6",
"future>=0.16.0",
- "pycrypto>=2.6.1",
"requests>=2.13.0",
"six>=1.10.0",
"websocket-client>=0.40.0"
+ ],
+ keywords='policy dcae controller',
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python :: 2.7'
]
)