summaryrefslogtreecommitdiffstats
path: root/dmaap/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'dmaap/setup.py')
-rw-r--r--dmaap/setup.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/dmaap/setup.py b/dmaap/setup.py
new file mode 100644
index 0000000..1bdb14f
--- /dev/null
+++ b/dmaap/setup.py
@@ -0,0 +1,36 @@
+# ============LICENSE_START====================================================
+# =============================================================================
+# Copyright (c) 2020 AT&T Intellectual Property. All rights reserved.
+# Copyright (c) 2020 Pantheon.tech. All rights reserved.
+# =============================================================================
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+# ============LICENSE_END======================================================
+
+from setuptools import setup, find_packages
+
+setup(
+ name = "dmaap",
+ version = "1.5.0",
+ packages=find_packages(),
+ author = "AT&T",
+ description = ("Cloudify plugin for creating DMaaP feeds and topics, and setting up publishers and subscribers."),
+ license = "",
+ keywords = "",
+ url = "",
+ zip_safe=False,
+ install_requires=[
+ 'python-consul>=0.7.0',
+ 'requests',
+ 'cloudify-common>=5.0.5',
+ ],
+)