summaryrefslogtreecommitdiffstats
path: root/k8s/setup.py
diff options
context:
space:
mode:
authorJoanna Jeremicz <joanna.jeremicz@nokia.com>2020-06-26 16:53:53 +0200
committerJoanna Jeremicz <joanna.jeremicz@nokia.com>2020-07-24 16:10:20 +0200
commitbd7d70b16ffce30e31acd0bf1013b1392ca5fb81 (patch)
tree4ebec55ebd75a40d82c2290acba9e95490de0e58 /k8s/setup.py
parentc5abb9b34468400bdcdd3ce23595af41ac03cd80 (diff)
Add support to request certificates from CMPv2 server in DCAE cloudify blueprints
If the blueprint specifies that the component uses external TLS via the `external_cert` property, the `Deployment` includes an additional init container and the component's container. The init container populates the external TLS certificate artifacts in mounted volume. The container requires CMPv2 CertService to work properly. Issue-ID: DCAEGEN2-2252 Signed-off-by: Joanna Jeremicz <joanna.jeremicz@nokia.com> Change-Id: I90cb79120ffaf634fc1f5b8a03a83abb30deb2b7
Diffstat (limited to 'k8s/setup.py')
-rw-r--r--k8s/setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/k8s/setup.py b/k8s/setup.py
index 6c82295..fbe623c 100644
--- a/k8s/setup.py
+++ b/k8s/setup.py
@@ -3,6 +3,7 @@
# ================================================================================
# Copyright (c) 2017-2020 AT&T Intellectual Property. All rights reserved.
# Copyright (c) 2020 Pantheon.tech. All rights reserved.
+# Copyright (c) 2020 Nokia. All rights reserved.
# ================================================================================
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -22,8 +23,8 @@ from setuptools import setup
setup(
name='k8splugin',
description='Cloudify plugin for containerized components deployed using Kubernetes',
- version="3.0.0",
- author='J. F. Lucas, Michael Hwang, Tommy Carpenter',
+ version="3.1.0",
+ author='J. F. Lucas, Michael Hwang, Tommy Carpenter, Joanna Jeremicz',
packages=['k8splugin','k8sclient','configure'],
zip_safe=False,
install_requires=[