summaryrefslogtreecommitdiffstats
path: root/k8s/setup.py
diff options
context:
space:
mode:
authorMiroslav Los <miroslav.los@pantheon.tech>2019-12-18 18:28:59 +0100
committerMiroslav Los <miroslav.los@pantheon.tech>2020-01-17 19:02:50 +0100
commitb10bd92fc39633dbfffba2e5bd5c4630baf880e6 (patch)
treea58da0e1a1b53869553cb94f8619d97daf0bca09 /k8s/setup.py
parent0208d99f681e2a0f00a4f0cd8e7a45f41ea67c1a (diff)
Address k8s plugin code smells reported by sonar
Make 'resources' argument to k8sclient.k8sclient.deploy an optional kwarg, update its uses and document it. Split off code reported complex from deploy into functions. Tweak a nested if in tasks. Signed-off-by: Miroslav Los <miroslav.los@pantheon.tech> Issue-ID: DCAEGEN2-2006 Change-Id: I13a091de9207bab1c7d4eee3179263c5d994ffbf
Diffstat (limited to 'k8s/setup.py')
-rw-r--r--k8s/setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/k8s/setup.py b/k8s/setup.py
index 8a4cb7c..0b4f366 100644
--- a/k8s/setup.py
+++ b/k8s/setup.py
@@ -2,7 +2,7 @@
# org.onap.dcae
# ================================================================================
# Copyright (c) 2017-2019 AT&T Intellectual Property. All rights reserved.
-# Copyright (c) 2019 Pantheon.tech. All rights reserved.
+# Copyright (c) 2020 Pantheon.tech. All rights reserved.
# ================================================================================
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -24,7 +24,7 @@ from setuptools import setup
setup(
name='k8splugin',
description='Cloudify plugin for containerized components deployed using Kubernetes',
- version="1.7.1",
+ version="1.7.2",
author='J. F. Lucas, Michael Hwang, Tommy Carpenter',
packages=['k8splugin','k8sclient','msb','configure'],
zip_safe=False,