summaryrefslogtreecommitdiffstats
path: root/k8s/setup.py
diff options
context:
space:
mode:
authorMiroslav Los <miroslav.los@pantheon.tech>2019-12-09 18:20:59 +0100
committerMiroslav Los <miroslav.los@pantheon.tech>2019-12-12 17:46:28 +0100
commit4435e8803a6844245d2529cae840a3d55d84c296 (patch)
tree495b8e368934755342190ab6047109c467304243 /k8s/setup.py
parent4682668e697b71bbc1be4133cb66fad0df1b735b (diff)
Customize python import for kubernetes plugin
Cloudify manager fails to find the plugin without this helper. The original code, cloudify-python-importer, is unmaintained. It is just one module, licensed under Apache2.0 as well. It also needs a python3 fix, hence the module code is added here. Note that what the modification does should not be necessary, and a proper root cause and fix needs to be found eventually. Signed-off-by: Miroslav Los <miroslav.los@pantheon.tech> Issue-ID: DCAEGEN2-1988 Change-Id: I28274dff902204362d7f5b6f97ac3381ff8b5411
Diffstat (limited to 'k8s/setup.py')
-rw-r--r--k8s/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/k8s/setup.py b/k8s/setup.py
index 6e8e96c..8a4cb7c 100644
--- a/k8s/setup.py
+++ b/k8s/setup.py
@@ -24,7 +24,7 @@ from setuptools import setup
setup(
name='k8splugin',
description='Cloudify plugin for containerized components deployed using Kubernetes',
- version="1.7.0",
+ version="1.7.1",
author='J. F. Lucas, Michael Hwang, Tommy Carpenter',
packages=['k8splugin','k8sclient','msb','configure'],
zip_safe=False,