summaryrefslogtreecommitdiffstats
path: root/k8s/setup.py
diff options
context:
space:
mode:
authorJack Lucas <jflucas@research.att.com>2019-07-03 11:13:25 -0400
committerJack Lucas <jflucas@research.att.com>2019-07-17 10:07:18 -0400
commit91f452a988c05fc901a5b4ca0ac76eefb6be3a3c (patch)
tree9e7da92ec82b42da5bfe07ec497ac507187a6a62 /k8s/setup.py
parent9c094d0581c46d3d107facdc55cb2cc7a1d9f765 (diff)
Move DR subscriber creation before container start5.0.2-ONAP5.0.1-ONAPelalto
Also update Kubernetes client library version Fix bug that allowed generating a too-long k8s deployment name. Issue-ID: DCAEGEN2-1651 Issue-ID: DCAEGEN2-1653 Issue-ID: DCAEGEN2-1667 Change-Id: Ied859073fb01d8623278cf9e58c1dcc26fed1712 Signed-off-by: Jack Lucas <jflucas@research.att.com>
Diffstat (limited to 'k8s/setup.py')
-rw-r--r--k8s/setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/k8s/setup.py b/k8s/setup.py
index 5d27438..b0e43f6 100644
--- a/k8s/setup.py
+++ b/k8s/setup.py
@@ -23,7 +23,7 @@ from setuptools import setup
setup(
name='k8splugin',
description='Cloudify plugin for containerized components deployed using Kubernetes',
- version="1.5.0",
+ version="1.6.0",
author='J. F. Lucas, Michael Hwang, Tommy Carpenter',
packages=['k8splugin','k8sclient','msb','configure'],
zip_safe=False,
@@ -33,6 +33,6 @@ setup(
"onap-dcae-dcaepolicy-lib>=2.4.1,<3.0.0",
"cloudify-plugins-common==3.4",
"cloudify-python-importer==0.1.0",
- "kubernetes==4.0.0"
+ "kubernetes==9.0.0"
]
)