aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorTommy Carpenter <tommy@research.att.com>2017-08-11 15:02:32 -0400
committerTommy Carpenter <tommy@research.att.com>2017-08-11 19:12:47 +0000
commit0581c1ed0320acd612dc38757744e8cc1212014b (patch)
tree7a9f4dbb689f56307c4ad1ca03d942c77d30b6b5 /setup.py
parent816ac43c7c53508ca3ec174f38bd49d1583f1d12 (diff)
Intial commit of CBS to ONAP
Change-Id: I2082544efc59476ac8de0dc39c899f968c3847bd Signed-off-by: Tommy Carpenter <tommy@research.att.com> Issue-Id: DCAEGEN2-47
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py40
1 files changed, 40 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..cc28a43
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,40 @@
+# ============LICENSE_START=======================================================
+# org.onap.dcae
+# ================================================================================
+# Copyright (c) 2017 AT&T Intellectual Property. All rights reserved.
+# ================================================================================
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+# ============LICENSE_END=========================================================
+#
+# ECOMP is a trademark and service mark of AT&T Intellectual Property.
+import os
+from setuptools import setup, find_packages
+from pip.req import parse_requirements
+from pip.download import PipSession
+
+import pip
+pip.main(['install','-r','requirements.txt'])
+
+setup(
+ name='config_binding_service',
+ version='1.2.0',
+ packages=find_packages(),
+ author = "Tommy Carpenter",
+ author_email = "tommy at research dot a t t dot com",
+ description='Service to fetch and bind configurations',
+ license = "",
+ keywords = "",
+ url = "ONAP URL TBD",
+ zip_safe=False,
+ scripts = ["bin/run.py"]
+)