aboutsummaryrefslogtreecommitdiffstats
path: root/app/app/setup.py
diff options
context:
space:
mode:
authorTommy Carpenter <tommy@research.att.com>2019-02-20 07:34:09 -0500
committerTommy Carpenter <tommy@research.att.com>2019-02-20 13:46:44 -0500
commit3b60a76f14d035b4e3ca818e07815785ce5a7746 (patch)
treef5804c7e62f2a36651726f5726d86ebbc4051e61 /app/app/setup.py
parent58c2dfb5bf159488dd04cae572af93c975926d1c (diff)
Switch to openapi3, clean up testing4.0.0-ONAPdublin
Issue-ID: DCAEGEN2-1215 Change-Id: I29cb31faa497233635de19d211f633f34692d511 Signed-off-by: Tommy Carpenter <tommy@research.att.com>
Diffstat (limited to 'app/app/setup.py')
-rw-r--r--app/app/setup.py11
1 files changed, 7 insertions, 4 deletions
diff --git a/app/app/setup.py b/app/app/setup.py
index 65ff0b6..38929c9 100644
--- a/app/app/setup.py
+++ b/app/app/setup.py
@@ -1,5 +1,5 @@
# ============LICENSE_START=======================================================
-# Copyright (c) 2017-2018 AT&T Intellectual Property. All rights reserved.
+# Copyright (c) 2017-2019 AT&T Intellectual Property. All rights reserved.
# ================================================================================
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -20,12 +20,15 @@ from setuptools import setup, find_packages
setup(
name='config_binding_service',
- version='2.2.5',
+ version='2.3.0',
packages=find_packages(exclude=["tests.*", "tests"]),
author="Tommy Carpenter",
author_email="tommy@research.att.com",
description='Service to fetch and bind configurations',
url="https://gerrit.onap.org/r/#/admin/projects/dcaegen2/platform/configbinding",
- install_requires=["requests", "Flask", "connexion", "six"],
- include_package_data=True
+ install_requires=["requests",
+ "Flask",
+ "six",
+ "connexion[swagger-ui]"],
+ package_data={'config_binding_service': ['openapi.yaml']}
)