summaryrefslogtreecommitdiffstats
path: root/mod/onboardingapi/setup.py
diff options
context:
space:
mode:
authorMichal Jagiello <michal.jagiello@t-mobile.pl>2020-08-26 12:32:50 +0000
committerMichal Jagiello <michal.jagiello@t-mobile.pl>2020-08-27 08:00:39 +0000
commit72dc0c883bfbc27dfe240d06f1871a85b4a2fd35 (patch)
treea1f59fb43da73b6905e48c3bd8a71b3f14146935 /mod/onboardingapi/setup.py
parent66ae1f86dd66a064c6095fce19bc7dd6dd072473 (diff)
Run in Python 3.8
Use Docker image prepared by integration team Issue-ID: DCAEGEN2-2292 Signed-off-by: Michal Jagiello <michal.jagiello@t-mobile.pl> Change-Id: I4d147c14d0a6a0c93648b07567ccd7b6b594f0f1
Diffstat (limited to 'mod/onboardingapi/setup.py')
-rw-r--r--mod/onboardingapi/setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/mod/onboardingapi/setup.py b/mod/onboardingapi/setup.py
index 6ad35a7..12eabc0 100644
--- a/mod/onboardingapi/setup.py
+++ b/mod/onboardingapi/setup.py
@@ -2,6 +2,7 @@
# org.onap.dcae
# ================================================================================
# Copyright (c) 2017-2018 AT&T Intellectual Property. All rights reserved.
+# Copyright 2020 Deutsche Telekom. All rights reserved.
# ================================================================================
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -44,15 +45,14 @@ setup(
setup_requires=['pytest-runner'],
install_requires=[
'Werkzeug==0.16.1',
- 'python-consul<1.0.0',
+ 'python-consul<1.0.0',
'six',
'sqlalchemy',
'SQLAlchemy-Utils',
'click>=6.0,<7.0',
'jsonschema',
'terminaltables',
- 'psycopg2==2.7.5',
- 'psycopg2-binary==2.7.5',
+ 'psycopg2-binary==2.8.5',
'genson',
'flask-restplus',
'onap-dcae-discovery-client>=2.0.0',