summaryrefslogtreecommitdiffstats
path: root/dcae-cli/pom.xml
diff options
context:
space:
mode:
Diffstat (limited to 'dcae-cli/pom.xml')
-rw-r--r--dcae-cli/pom.xml13
1 files changed, 3 insertions, 10 deletions
diff --git a/dcae-cli/pom.xml b/dcae-cli/pom.xml
index f8b9e8a..dbf5cef 100644
--- a/dcae-cli/pom.xml
+++ b/dcae-cli/pom.xml
@@ -33,19 +33,12 @@ ECOMP is a trademark and service mark of AT&T Intellectual Property.
<properties>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<sonar.sources>.</sonar.sources>
- <!-- customize the SONARQUBE URL -->
- <!-- sonar.host.url>http://localhost:9000</sonar.host.url -->
- <!-- below are language dependent -->
- <!-- for Python -->
+ <sonar.junit.reportsPath>xunit-results.xml</sonar.junit.reportsPath>
+ <sonar.python.coverage.reportPath>coverage.xml</sonar.python.coverage.reportPath>
<sonar.language>py</sonar.language>
<sonar.pluginName>Python</sonar.pluginName>
<sonar.inclusions>**/*.py</sonar.inclusions>
- <!-- for JavaScaript -->
- <!--
- <sonar.language>js</sonar.language>
- <sonar.pluginName>JS</sonar.pluginName>
- <sonar.inclusions>**/*.js</sonar.inclusions>
- -->
+ <sonar.exclusions>tests/*,setup.py</sonar.exclusions>
</properties>
<build>
<finalName>${project.artifactId}-${project.version}</finalName>