summaryrefslogtreecommitdiffstats
path: root/dcae-cli/setup.py
diff options
context:
space:
mode:
authorMichael Hwang <mhwang@research.att.com>2018-08-01 16:22:13 -0400
committerMichael Hwang <mhwang@research.att.com>2018-08-03 10:33:58 -0400
commit2de95edebaa92072aa857ca70961cd7bdaf7a77d (patch)
tree5225035b16b57d392ddbf3f38d340b4fa28f9a0c /dcae-cli/setup.py
parentc4a139fff38bc62ea0a47566707c7aad13a86b4f (diff)
Do first pass on dcae onboarding vagrant
* Provide Vagrantfile etc to standup a VirtualBox image that runs a minimal DCAE runtime for onboarding * Add README with directions on how to do above * Make minor fixes to the dcae-cli for issues discovered from testing above Issue-ID: DCAEGEN2-574 Change-Id: I99ea595df9e5e2b9a872b864e553caec1f020669 Signed-off-by: Michael Hwang <mhwang@research.att.com>
Diffstat (limited to 'dcae-cli/setup.py')
-rw-r--r--dcae-cli/setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/dcae-cli/setup.py b/dcae-cli/setup.py
index 9cfdd3f..d5f5dcc 100644
--- a/dcae-cli/setup.py
+++ b/dcae-cli/setup.py
@@ -1,7 +1,7 @@
# ============LICENSE_START=======================================================
# org.onap.dcae
# ================================================================================
-# Copyright (c) 2017 AT&T Intellectual Property. All rights reserved.
+# Copyright (c) 2017-2018 AT&T Intellectual Property. All rights reserved.
# ================================================================================
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -42,7 +42,7 @@ setup(
dcae_cli=dcae_cli.cli:cli
""",
setup_requires=['pytest-runner'],
- install_requires=['python-consul',
+ install_requires=['python-consul<1.0.0',
'six',
'sqlalchemy',
'SQLAlchemy-Utils',
@@ -50,6 +50,7 @@ setup(
'jsonschema',
'terminaltables',
'psycopg2',
+ 'psycopg2-binary',
'genson',
'onap-dcae-discovery-client>=2.0.0',
'onap-dcae-dockering>=1.0.0,<2.0.0'